Problems opening Komodo IDE 10

I’ve been using Komodo 8 up until now - don’t use it very frequently - and decided today to install Komodo IDE 10. I reinstalled my licence then installed Komodo. I accepted some of the options then I got what seemed like the initial page but I got the spinning ball and nothing else happened. I looked at the Force Quit Applications window and it showed Komodo there as not responding so I tried to force quit it. This didn’t work at all and my whole Mac seized up with my only option to switch it off.

I’m running El Capitan 10.11.5.

That’s very unusual. Does this happen every time you try to start Komodo?

Could you please post your pystderr.log file?

Yes it does, and I’ve just tried it again. Spinning ball and again Force Quit Applications showed it as not responding. This time I didn’t try to force quit it but when i viewed Komodo again the ball had stopped spinning but everything was locked. I have found that if i open up in Safe mode I can run Komodo OK!

I’m posting pystderr.log file shortly as requested by nathanr

I’ve located the pystderr.log file OK but the system is not allowing me to upload a file with a .log extension - how can I get round this? It seems too large to just paste the contents into the post.

Upload it on Dropbox.

Here’s a link to the pystderr.log file - pystderr.log file

Grand thanks, have now done this.

Very odd, seems to have some type of corruption. To find out whether it is your install or your profile please try starting Komodo with a clean profile:

Some time ago I’d tried Komodo IDE 9. It had opened OK but I’d problems opening up files so I went back the earlier version 8.

I’ve now deleted the folders for 9 and 10. Version 10 now opens OK and has opened up the files I was last working on with version 8 - great.

Many thanks for your help.