Problem with Tab-ing and Dedent is no longer available

I am testing IDE 9.2.1 for OSX coming from IDE 8.5

I am having a problem with tabbing & dedenting and not sure if it’s just me.

  1. If I select a group of text and hit tab, the text is correctly indented. However I can not highlight the same text, or any text anywhere for that matter and Dedent it from the Code => Dedent menu. All the Indent, Dedent and tabify options are greyed out.

  1. For some reason I can not get my tab/indent preferences to override the tabs in an existing file.
    I have the tab indent set to 4 spaces. If I open a txt file that for some reason has a tab at 20+ characters there is nothing I can do to make 1 tab/indent be equal to 4 spaces.

I have tried creating a new file and entering some text. I named that file new.txt the file has proper indenting.

Then I copy text from my old.txt with odd indenting. paste the text into new.txt and the indenting is correct. So far so good.

However, if I then close old.txt and file => saveas new.txt as old.txt the tab stops revert to the prev incorrect positions from old.txt even tho I am saving over the top of it.

The menu issue is a separate issue which I believe is resolved in 9.3. I’m not seeing it any way. You can get 9.3 from our downloads website if you want to try it:

Indent/Dedent should work fine through Tab and Shift + Tab respectively.

For the issue where you can’t change your indent settings for a file, this must be because you set it in that file at some point. File level prefs reign supreme in Komodo. There are two options:

  1. For every file you notice this problem, change the preferences for the file: Edit menu > Current File Preferences.
  2. Clear all file level prefs by deleting doc-state.xmlc (while Komodo is not running) from ~/Library/Application Support/KomodoIDE/9.2/

Let us know this your still have issues.


Thanks, upgrading to 9.3 solved all of the problems in this post. No other changes were necessary.

my indent-dedent with the Tab key is all jacked up again… with the latest update to 9.3.2
I cannot tab a block of code forward or backward consistently.

single lines seem to work… but a multi-line

Does the problem go away when you do Help > Troubleshooting > Reset File Preferences and restart Komodo?

No. Tired resetting UI Prefs too… didn’t work.

Okay, well you’ve given us very little to go on other than “it doesn’t work”. Do you have a sample file we could look at? Some specific details as to what/where exactly you’re experiencing the problem? The more information you provide, the more likely it is that we can help diagnose the problem.

works fine in Sublime. Bye.

Nothing to discuss there. For anyone who’ll be experiencing the same problem - please create a new topic :smiley: