Problem with PHP autocomplete on array()


#1

I’ve used Komodo Edit for years, and have just switched to using version 12 of Komodo IDE, and I’m having a problem with what I think is an autocomplete in PHP.

I want to type:

array ()

But when I get to the space after ‘array’ it autocompletes to:

$array = array();

This might be useful in some cases, but for 99% of what I do it’s extra work to go back and delete everything that isn’t needed.

Is there any way that I can turn off that specific function, or a way to disable it by any other method?


#2

Morning @catacaustic,

This is Auto-Abbreviations.

You can either find and alter the offending Abbreviation in your toolbox; View menu > Tabs & Sidebars > Toolbox, Abbreviations > PHP > array.

OR disable Auto-Abbreviation in Prefs; Edit menu (Komodo menu on OSX) > Preferences > Editor > Smart Editing > Auto-Abbreviations.

  • Carey

#3

Hi Carey,

Thanks so much, that’s exactly what I was hoping for! I’m also glad to learn about that feature so I can hopefully use it more for myself in the future.