PHP debugging works fine in Komodo Edit but not Komodo IDE


I installed Komodo IDE on same computer with Komodo Edit already installed.

PHP debugging works fine in Komodo Edit, but when I set the same php.exe and php.ini file in Komodo IDE, it says WARNING Failed to Configure for Local PHP debugging.

Why do the settings that work in Edit not work in IDE?

And a second question, what is Drush (its not an option in Edit).


@jshrek, Komodo Edit does not have debugging. I’m not sure what you’re referring to. What do you mean by “debugging” in Komodo Edit?


Yes it does … Or maybe I am using the wrong term?

When I write code in PHP, the debugger (that’s what I call it) up at the top checks my code and tells me if there is a syntax error somewhere.
See attached Komodo Edit screen shot with little red circle at the top and see also the Komodo Edit preferences screen shot with setup that I am using.

When I use these exact same preferences in Komodo IDE for the php interpreter and ini file, it says it failed to configure local debugging (hence why I am calling this debugging).

Screenshots of Komodo EDIT:

Scrrenshot Komodo IDE:

@jshrek, when in doubt, read the docs:

Debugging is IDE only. You’re just setting an interpreter there. You can’t start a debug session in Komodo Edit.

Ok so the title of this post needs to be changed to:
PHP Syntax Checking works fine in Komodo Edit but not in Komodo IDE

It is the syntax checking that I can not get to work, even if I have the interpreter set the same in both IDE and Edit.

So based on all the information I posted above, why is syntax checking for PHP not working in Komodo IDE?


Please do that.

What does Edit menu > Preferences > Syntax & Spell Checking say when you have PHP selected?