Permission denied on prefs.xmlc

Help! Similar problem, but:

  • The hamburger menu does not respond
  • Pressing ALT does not show the menu bar
  • ALT+E, E does not bring up preferences.
  • Other ALT-* shortcuts do work, so it does see the ALT key
  • Pressing the “PHP” icon for “view as language” does not respond
  • Right-clicking on code in editor does nothing

Usually the hamburger is on the upper right, but today it was where it is in the screenshot above. Restarting does not solve the problem.

So far this seems to have worked: delete ~/.komodoide/9.2, replace tools/, templates/ and schemes/ with previous versions, restart. So far so good. Some old prefs must be restored manually.

Could corrupted prefs files cause all this?

Some screenshots of pystderr.log after problems occurred below.

Suggestions very much appreciated! Don’t want this to reoccur. Thanks.

Komodo Version: IDE 9.2.1
OS: Linux 3.10.0-229.14.1.el7.x86_64 #1 SMP Tue Sep 15 05:09:55 CDT 2015 x86_64 x86_64 x86_64 GNU/Linux

@RockM66, If you’re able to reproduce this after resetting your preferences then please file a bug:

If you do, please copy and paste your logs into the bug report rather than taking a screenshot.

I do see an error in your logs about the cached prefs not loading. You might have had corrupted prefs and that was effecting your UI in some way. The Alt key examples that access the menu, that you gave are the same issue that I saw but not being able to use the hamburger menu is something else.

Please do file a new bug if you see this again.

  • Carey

A similar problem occurred, but still not sure how to reproduce. This same line occurred in the log:

[WARNING] koXMLPrefs: dePickleCache: Can’t open file u’/usr/local/Komodo-IDE-9.3.0/lib/support/prefs.xmlc’

The usr/local/…/prefs.xmlc is root-owned file with permissions=600, so it can’t be opened. Is this the cached prefs? Are the permissions supposed to be that way?

Changing permissions does not fix, still had to delete ~/.komodoide/9.3 and start over.

Here’s what my screen look like this time, even worse than before:

I think this must be related to how you installed Komodo.

Please uninstall Komodo then follow the docs here:

If you need to use sudo to install Komodo then you have to change the ownership of the install directory to your user. I recommend just using the default install directory though.

  • Carey

Yes, it would appear I need sudo/root to run, otherwise I get an error: permission denied: etc/selinux/targeted/contexts/files/file_contexts.bin. I’ve always installed Komodo as root in the past and didn’t have this problem until 9.2-9.3.

I went ahead an re-installed as root and did chown -R on the install directory, so far so good, thanks.

Just curious, are the prefs.xmlc really supposed to have persmissions=600 or is that a bug? That, is that file supposed to be nonreadable except by the installer user?

Not to point fingers but it’s likely that you aren’t recalling all the steps you took last time you install Komodo and it was working properly so you’re now having an issue.

It is possible that I’m not remembering a change that might have effect permissions but then I think more people would be hitting your issue.

That is the correct permissions on the prefs files.

I’m breaking this off from the original thread as it is not the same issue.

  • Carey

Yup, it’s possible something changed in my install, although I think it’s just pretty much Changing owner hopefully will be a permanent solution, so far so good. Thanks for moving this.

I just meant that perhaps you had changed permissions before but didn’t recall doing so. Any way, glad you’re set! Glad we could get you sorted out.

  • Carey