Performance OSX wide column files

When scrolling through files, the code jumps and is delayed. This is a small file at 73KB. It is an xml file (but I also have similar problems with all file types.). This file is extremely wide. Some columns reach 455 in length.

I don’t have this problem on my windows machine.

I am using a brand new imac with a bluetooth mouse (not sure if that would be relevant). I don’t think it should have any problem processing this file. The hardware is sufficient.

Are there any settings I should look at to see if I can get this running smoothly. The performance on the mac machine seems to be undesirable.

I can open this same file in almost any other editor and have it scroll smoothly.

My settings are pretty much stock.

Any assistance would be greatly appreciated.

I think the column length is the key thing here.

So enabling wordwrap greatly increases the scrollability of the file. I can actually scan through the file instead of it jumping and being delayed.

Hey Mike,

What version of Komodo are you using? (Komodo > About Komodo)
So you have minimap enabled as well? (View > View Minimap) You could try disabling it.

  • Carey

build 83298 (8.5.3)

I do not have the mini map enabled. I actually went through almost everything, git, code intelligence, syntax highlighting and none of those helped. But when I enabled word wrap, everything worked smoothly. I really thing it has something to do with the super long columns.

Hey Mike, are you able to post a sample (or create a Komodo bug and attach the file) - that way we repro it and hopefully fix/incorporate it into Komodo’s test suite.

It has a test file.