Open a Debugger Port


I am using the latest version of the full-featured Komodo IDE on the latest version of Windows 10 with all the latest updates to run the latest version of Python 3.

When I start the debugger or run without debugging, I get a debugging options dialog, followed by a dialog that says:

Unable to initialize the debugging system because Debugging will be unavailable until you
change the debugger port in your preferences. You can try allowing the system to provide
a free port. - Debugger Initialization Error

I am starting programming after a long time, so I have no clue how to post log files, but I believe the ports are open. Please help. Thanks!

@whippoorwill5, sounds like something else is using the port that Komodo usually uses on localhost for debugging connections. You should be able to change this in Edit menu (Komodo on OSX) > Preferences > Debugger > Connection

@careyh: I managed to fix three problems:

  1. It seems that the debugging options dialog is not a bug in my program or settings but a feature of Komodo: it is always meant to appear. I changed this in preferences, never to show it.

  2. I uninstalled and reinstalled both Python and Komodo, and the program started executing. I also had to set the interpreter path to point to where python is installed. I did not change any port settings either in Windows or Komodo or the wifi router.

  3. At that point, the programs started running, but it was still showing some ‘state’ error in the notifications pane, which was fixed by running a Windows Powershell command.


1 Like