Not reading git status correctly

Komodo IDE 8.5.4; Ubuntu 13.01, 32bit

This is not bug #97855.

Over the past few weeks, Komodo IDE has sometimes failed to display the correct SCC status for files (e.g., showing the “changed” icon to files already committed and up-to-date). The “Refresh Status” option has no effect.

I upgraded to 8.5.4 hoping it would solve these problems. As a result, I encountered (and worked around) bug #97855. However, the original problem persists.

At the moment, Komodo is not recognizing that my project files are even part of a git repo. The only SCC command available is “Add,” which Komodo reports succeeds, but produces no changes in the Komodo UI (nor in git, since the files are actually already committed to the repo). Note; these are files in a repo that was working correctly in Komodo just yesterday. There have been no changes (absolutely none - and the repo still works fine from the cli) to the repo, and the problem appeared in Komodo before I upgraded to 8.5.4.

Any insights would be appreciated. Thanks,

also tried resetting the user data directory, with no effect.

Anything in the Komodo error log? Use (Help > Troubleshooting > View log file) to access the log.

What version of git are you using? Have you tried, if possible, a newer version?

I’m using Komodo 8.5.4 in Scientific Linux 6.5. When I set Preferences/SCC/Git/executable=/usr/bin/git, which is git 1.7.1, I have the same problem: repo files are not recognized as being such. There is no git status data. However, when I change the executable path to point to a source installation of git 2.1.2, everything seems fine: there are icons indicating file status (the icons change when changes are made, and again when the files are staged).