Node.js debugger never finishes starting

I’m trying to debug a simple Node.js program locally and when I choose “Step Into” in Komodo, the debug status shows “Debugger is starting…” but never proceeds.

I’ve also tried adding “–debug” to the Interpreter Arguments which shows “Debugger listening on port 5858” in the Output window, but still does not step into the source code. The test program works fine outside of Komodo.

Komodo V8.5.4
Node.js v0.12.1
Mac OS X 10.10.2

Any suggestions to get this working?

Hi @rxdominy,

Komodo debugger currently only supports Node 10. That would be why it’s not working for you.

  • Carey

Thanks, Carey. Is that true also of the newly released Komodo 9 as well?

Unfortunately yes. We’ll be hopefully be able to upgrade it in one of the Komodo 9 point releases.

  • Carey

I’m having the same problem. Komodo IDE, version 9.0.1, build 87208, platform win32-x86. (Windows 8.1)

Per advice above, I tried uninstalling Node v0.12.2, and installing Node v0.11.16… no difference.

I’m feeling a bit noob. What am I doing wrong? Is there an earlier version of v0.11 I should try?

I was only able to get it working with the last stable node release: 0.10.36

Thanks @rxdominy. That seems to work. Well, it’s not hitting my breakpoints, but that’s probably another issue.

My mistake. I meant Node 10, not 11. I’ve edited my previous post.