No supported terminal was found, please install xterm


#1

Hi!
I recently upgraded from Komodo Edit 11 to Komodo IDE 12 but I am facing a few issues.

  • when running a custom command I get a window saying No supported terminal was found, please install xterm. xterm is installed. I tried different installations with no success. I don’t know how to tell Komodo IDE where to find it.
  • code intelligence does not work for me. It was working at times on Edit 11. I have a python+js project, if I ctrl+click or ctrl+k,ctrl+g on some internal or external class definition nothing happens on IDE 12.
  • the size of the window with the new interface is too large and not resizable. If I switch to classic mode with native orders it’s fine but sometimes, in split view the two windows change size as I focus on them.

My OS is a Linux Mint 19.3 Cinnamon.
Thanks in advance for your help!


#2

Hi @brigantino2,

Xterm was removed from the latest releases of Ubuntu derivatives. You’ll need to install it manually I believe.

Ctrl + Click was removed in Komodo IDE 11. You can right click > Go to definition. If that doesn’t work I’d give Komodo 10 a shot to see if the updated code intel might not be working with your project.

You’ll need to be more specific on point 3. I don’t know what you’re referring too. Screenshots would be helpful.

  • Carey

#3

Hi @careyh,

Thank you for your answer.
Xterm is installed system-wide. I tried reinstalling it in different ways but it seems not to be available to Ide 12 (while everything works fine in Edit 11.1).

Click + Go to Definition also doesn’t work on Ide 12. On Edit 11.1 it was working at times, like sometimes it was going to definition, other times not. I’m wondering if there is anything I can configure to define (or limit) the folders codeintel looks into, in order not to have a huge file base to search.

I’m uploading two screenshots, the first one as I open the editor, the second one when I click on the right split view area. You can notice the left box shrinks to a smaller size. This happens sometimes when you focus from a box to another.


#4

I’ll need more information about this then. What is the custom command you’ve made? How are you running it? Off the top of my head I’d check your Preferences > Environment to see if you’re overriding your system $PATH or if you’re overriding $TERM.

Code inte: You can limit the scan depth in your Preferences > Code intel. You may be missing Additional [Language] Import Directories from your Preferences > Language > [Language name] prefs as well. Other wise you could try Help > Troubleshooting > Reset Code intel.

Window size: Does it sound related to this? https://github.com/Komodo/KomodoEdit/issues/1536

Note: next time please open different threads for each problem. We shouldn’t be debugging 3 different problems in one thread. It makes it harder on us and not helpful for people in the future that come across this for help.

  • Carey

#5

All right, yes, I was overriding the system $PATH in my project preferences. I deleted my custom $PATH and now it’s working.

Code Intel, I reset the code intel db and cache, but still no luck. But in case I will open a new thread for that.

Window size, yes it’s that issue.

Thank you for your support!


#6

That’s quite the Branch name you have there! Could you try disabling Git (or whatever Source Control tool you use), close and reopen the file on the right in your screenshot, then see if you can reproduce the issue?

Will keep an eye open for your Code Intel issue. When you open the new thread please include more details about it, eg. estimate size (num files), language, framework if used etc.

  • Carey