No stop at breakpoints


#1

I have komodo at windows. All files in c:/example
The server is at linux, all files in webroot/example

Normally i work directly at the server; before starting debugging i download the web to windows.
I tried to have all files from remote in places, open a file and set a breakpoint.
I tried to have all files from windows in places, open a files and set a brwakpoint.

Both times the breakpoint is no stop for the debug.

  1. In which file should i set the breakpoint? {remote|local}?
  2. How can i tell komodo not to open any file (like css, js and others); i am just interested in one of many files and the question why a method is not running twice how it should.

For this i need to see the arrays from post and what happens with them.
I have break at start, break at breakpoint. I tried f5 and also f6, f7, f8.
I can step through also, but it seems that the debugging stops the script sometimes?!

Is there anything is should change for xdebug?
This program makes use of the Zend Scripting Language Engine:
Zend Engine v3.2.0, Copyright © 1998-2018 Zend Technologies
with Xdebug v2.6.0

Version 2.6.0
IDE Key keyname

xdebug.auto_trace Off Off
xdebug.cli_color 1 1
xdebug.collect_assignments Off Off
xdebug.collect_includes On On
xdebug.collect_params 1 1
xdebug.collect_return Off Off
xdebug.collect_vars Off Off
xdebug.coverage_enable On On
xdebug.default_enable On On
xdebug.dump.COOKIE no value no value
xdebug.dump.ENV no value no value
xdebug.dump.FILES no value no value
xdebug.dump.GET no value no value
xdebug.dump.POST no value no value
xdebug.dump.REQUEST no value no value
xdebug.dump.SERVER no value no value
xdebug.dump.SESSION no value no value
xdebug.dump_globals On On
xdebug.dump_once On On
xdebug.dump_undefined Off Off
xdebug.extended_info On On
xdebug.file_link_format no value no value
xdebug.filename_format no value no value
xdebug.force_display_errors Off Off
xdebug.force_error_reporting 0 0
xdebug.gc_stats_enable Off Off
xdebug.gc_stats_output_dir /tmp /tmp
xdebug.gc_stats_output_name gcstats.%p gcstats.%p
xdebug.halt_level 0 0
xdebug.idekey adeva adeva
xdebug.max_nesting_level 256 256
xdebug.max_stack_frames -1 -1
xdebug.overload_var_dump 2 2
xdebug.profiler_aggregate Off Off
xdebug.profiler_append Off Off
xdebug.profiler_enable Off Off
xdebug.profiler_enable_trigger Off Off
xdebug.profiler_enable_trigger_value no value no value
xdebug.profiler_output_dir /tmp /tmp
xdebug.profiler_output_name cachegrind.out.%p cachegrind.out.%p
xdebug.remote_addr_header no value no value
xdebug.remote_autostart On On
xdebug.remote_connect_back Off Off
xdebug.remote_cookie_expire_time 3600 3600
xdebug.remote_enable On On
xdebug.remote_handler dbgp dbgp
xdebug.remote_host 192.168.1.1 192.168.1.1
xdebug.remote_log no value no value
xdebug.remote_mode req req
xdebug.remote_port 9000 9000
xdebug.remote_timeout 200 200
xdebug.scream Off Off
xdebug.show_error_trace Off Off
xdebug.show_exception_trace Off Off
xdebug.show_local_vars Off Off
xdebug.show_mem_delta Off Off
xdebug.trace_enable_trigger Off Off
xdebug.trace_enable_trigger_value no value no value
xdebug.trace_format 0 0
xdebug.trace_options 0 0
xdebug.trace_output_dir /tmp /tmp
xdebug.trace_output_name trace.%c trace.%c
xdebug.var_display_max_children 128 128
xdebug.var_display_max_data 512 512
xdebug.var_display_max_depth 3 3

Zend OPcache
I cant get rid of this; but it should be loaded (before or after) like read somewhere.


#2

Hi @anjade,

Can you confirm you’ve read through the PHP remote debugging documentation and followed those steps exactly? It sounds like you may not have as you are trying to debugging a webpage using F5 which is not how it’s start.

Please follow the instructions in the link below and let us know if you have issues after:
http://docs.activestate.com/komodo/11/manual/debugphp.html#remote-php-debugging

  • Carey

#3

Probably i have solved it now.
Maybe it was the xdebug - i have set more options now (some of the tried ones killed my apache)
Maybe it was the mapping. I thought i have to map ftp and local, but i have to map the browserfile with local or remote and also set the breakpoints to local or remote.
I also understand now, that an empty line is not exiting.