New Find Frame Issues on Linux

I’m considering reinstalling my KE 9.2 because the find function in 9.3 is so inconvenient. Maybe it’s just the Linux version.
I’ve tried a bunch of the default skins and colour schemes, but unless I’m in the Find or the Include pane I can’t see what is active (e.g., whole word or regex) when I tab through.
Because of what seems to be an incompatibility with Linux, I have to pin the Find window, but once I Esc it away, I still have to use keystrokes or the mouse to get the focus back to the editor.
I also have yet to see the usefulness of being able to tab through the Find popup to the tabs and back to the file.

I moved your post to a new thread as it’s not related to the thread you commented on.

Not being able to tell where you are is being tracked here: https://github.com/Komodo/KomodoEdit/issues/883

I don’t think this is being tracked. Could you file a new bug please?

I assume this is slightly tongue in cheek, I agree it’s not very useful :smiley: . This issue is being tracked here: https://github.com/Komodo/KomodoEdit/issues/888

Thanks for reaching out!

  • Carey

Yes, it is tongue in cheek. I hope it’s useful to someone.

I’m on windows 7 and backtracked to 9.1 for similar reasons :frowning:

Could you elaborate? As far as I know @hmw3 is happy now that he is using Komodo 9.3.1. Correct me if I’m wrong @hmw3.

  • Carey

Actually, I’m back at 8.5 (just because it never got uninstalled when I moved up to 9 – 9.2 worked fine, but it was replaced by the 9.3 installation). I can use 9.3.1 for a few minutes and then the Find function becomes non functional.

I usually have four separate Komodo windows open, each with three or four tabs. I do other work (involving multiple windows, some with multiple tabs) in Firefox. My Komodo work then involves searching databases, so I’m using the Find function to find information on which I run macros. (The macros never balk.) When I start 9.3, it works fine, but when I return after doing other work, after a few times going back and forth to other programs, the Find function doesn’t find. I can restart Komodo and it works fine at first, but then I have no idea when it will balk. If the Find function doesn’t work, then I’m dead, so I’ve gone back to 8.5. I’ll try again with 9.4 or 10.1, whichever is next.

That is concerning. That issue was fixed for 9.3.1 and was confirmed as fixed. Could you please elaborate?

Still waiting for more info here. We can’t fix issues that we don’t know about. Please let us know what issues you’re hitting and confirm you tried Komodo 9.3.1.

  • Carey

I’m not sure what more I could add to the post from yesterday. The only change I would make is to say that when the Find won’t find, the macros also balk.

It was with a saddened heart that I cancelled my subscription, I really thought Komodo was my final IDE.

I have complained in the past about Komodo always forcing “new improved” interfaces with often (usually?) no mechanism to revert to the previous method. This creates a learning curve (sometimes steep) for every release, and as a result is very disrupting to general workflow and productivity. In my previous complaints/rants I have mentioned that it is fine for a new product install to showcase what the product developers think is the UI paradigm at the time, but it is different entirely when a product upgrade forces that same “new” paradigm resulting in a change in workflow, an updated feature should always honour the users existing environment with the feature’s previous functionality and allow an option to “use the new presentation” rather than “here we are!”.

The biggest issues I have had over the years is the “find” dialogue, and I have made my fair share of recommendations, some of which have been incorporated. In one of the more recent versions (it shows as far back as 9.0, maybe earlier) is when I dismiss the find dialogue I always get an error popup, or if I switch to a different tab I get the same error popup. At least that doesn’t disrupt my workflow, it fades so I just ignore it.

In the most recent update it took a few moments to realize that the find was no longer a popup but 3 lines spread across the bottom of my screen. I use a 17" full HD laptop with the “standard” Komodo display options, that presents about 70 lines of text per page with just over 200 characters per line. So the first time I hit Ctrl-F I assumed I didn’t, so I did it several more times until I saw the “new improved” find version at the bottom of the page. Things got even worse when I tried “Find in Files”. Since the display width is fixed I now have the equivalent (as an example in fixed font) of about 175 characters for file specifications and 25 for include/exclude. I am usually searching many nested directories and so usually have a long list of “excludes” which sometimes becomes a long list of “includes”. The previous find dialogue used the same width for all the text boxes and dropdowns so these were all visible … need I say more? Now I see about 10% of the include and exclude lists :frowning:

All in all, this last release is a deal breaker. The Komodo team wants to direct the product wherever it feels it should with no regard to the needs of those who chose it in the first place for the features it offered at that time that were not available elsewhere. Have marketing think seriously about this last sentence …

A forum comment is definitely not a bug report. We track bugs in github: https://github.com/Komodo/KomodoEdit/issues/new. Please file a bug report for the issue if you’re still experiencing it.

Please elaborate. Is there an error? What do you mean by balk?

  • Carey

I’m sorry to hear that @PhilP, we introduced the new Find UX very early on in our nightly builds and had at that time decided that if we get negative feedback we would allow for the old UX as well. We had not received any significant negative feedback and so decided to launch only with the new UX. I know that doesn’t help you now but I just want to demonstrate that we absolutely do care about our existing users. I also want to point out that no functionality/feature was removed, the UX was only changed.

Staying relevant means that we always need to be evolving. While you may have liked the old Find dialog many others found it to be a pain point that broke an otherwise fluent user experience. As with any change we do try to minimize the impact it has on our existing users but at the end of the day we have to consider what the majority of our users want, and it doesn’t always make sense for us to offer a “way back” for the few users that don’t like the change as offering a way back also means we have to maintain and support it, which means we are spending time maintaining legacy UX where we could be spending that time fixing actual bugs, making enhancement or developing new features.

That doesn’t mean it doesn’t make me sad to read posts like this, we do try very hard to prevent frustrations like this and I will say that while we always had the best intentions we have made some mistakes in the past in regards to introducing new UX. We have learned from these mistakes and are/will be applying what we’ve learned through future releases.

Hi @PhilP,

Thanks for the feed back. I definitely understand where you’re coming from and the frustration of a changing product when you’re used to a tool. I also totally agree with @nathanr (I kind of have to…he’s my boss…kidding).

If you’ll humour me I do have a tiny bit of follow up as you have a few good points that should be addressed in the new dialog.

We’re not tracking an issue like this that I’m aware of. I know you’re no longer a Komodo community member but if you could point me to where you’ve reported this already or report it on Github I would appreciate it.

In your third paragraph I’m basically getting that you want the excludes and includes fields to be much wider. I totally agree though I never use them so it never came up. I don’t recall any one else mentioning it either but it’s a valid and good point. I need to clarify a couple points in there though. See below:

You want wider includes/excludes and a narrower file path field?

Thanks for you time and patiends, sorry to see you go.

  • Carey