Login failed, it appears you are offline

Downloaded the latest Komodo this morning (12.0.1-91869) for Windows 10 and can’t get past the initial launch due to the stated error “Login failed, it appears you are offline”. My system is very much online (posting this message using it), and I’ve verified that Komodo has network abilities through private and public networks in the Windows firewall settings.

I haven’t run into this issue before but am at a dead stop due to this issue as cancelling just closes Komodo.

Same issue here. Fresh download and install of Komodo IDE on Ubuntu 18.04, launching it prompts for login credentials, I enter my ActiveState login credentials but get “Login failed, it appears you are offline.” I can then create a new account (but it tells me an account exists with my email), or reset my password (resulting in the same problem), or cancel (and Komodo IDE quits). I log off of ActiveState in my browser and re-login using the same credentials I tried in Komodo IDE, and I log in just fine. So I have internet connectivity and I am using working credentials. Maybe the IDE is trying to establish connection to ActiveState using special port that I have to let through my firewall?

there are a bunch of errors in the log: invalid security certificates, unexpected EOD in json file, couldn’t download file, login failed…seems like there’s bugs in this version of Komodo IDE?

I want to share my log file, but as a new user I’m restricted (new users can’t mention more than 2 users in a post? new users can’t have more than 2 links in a post (and there are URL references in the log file).

I’m also having the same problem. After i enter the account information it just says “login failed you are offline”, i’ve tried restaring the PC and even reconnecting my Router.

Same problem on MacOS with 12.0.1-91869.

It seems that the certificate for platform.activestate.com:443 is not verified correctly.

[2020-06-01 09:14:29,733] [ERROR] console-logger: platform.activestate.com:443 uses an invalid security certificate.

The certificate is not trusted because the issuer certificate has expired.

My browser shows that this certificate is valid until august 8 2021. It is a wildcard certificate for *.activestate.com, maybe the wildcard causes the the problem.

I’m wanted to share my complete log file, but as a new user, I am not allowed to to id. When will I stop being considered as a “new user”. How can I share my log file?

Best regards

I’m able to reproduce the issue. We’re looking into it.

  • Carey

Same Issue.

Quick update, we’ve found the issue is due to Komodo not fully supporting the changes made by our SSL provider. We hope to have a solution deployed soon. Once resolved you’ll just need to restart Komodo.

Following up: The issue has been resolved and you should now be able to login to Komodo again. We apologize for the inconvenience!

  • Carey
1 Like

A post was split to a new topic: Collaboration Login Not Working

Just launched Komodo. Problem solved. Thank you.

Hi, I installed Komodo 12.0 a while ago, but didn’t launch it until now. I’m having the same login problem as described in this thread. Do I have to re-install Komodo?

@gpetrowitsch, it’s extremely unlikely you’re hitting the same issue. Please start a new thread to get your issue sorted out.

  • Carey

i thought i would start using KomodoIDE on windows but its not working with the error

1 Like

I thought this was resolved. I just downloaded Kimodo for the first time and I can’t even start it.


Same problem persists - Latest version as of 4/9/2021

Exactly the same here, I would love to hear how to solve this!

Hi Carey, I’m encountering the same problem still. Can someone help? cheers

Morning @ingmarglerum,

This issue is long since resolved so if you’re hitting it, it’s something else. This goes for everyone who’s posting on this thread: Please start a new thread.

  • Carey