Local PHP debugging trouble


#1

When I try to debug a php script I get a Debugger Error - PHP is not configured for debugging popup box. If I click on the Preferences button, I get to the PHP Languages where the Debugging Configuration says: Successfully configured for local PHP debugging.

When I try to: Run Without Debugging
The php script does seem to run but shows the following in the output first:
Failed loading C:\Program Files (x86)\ActiveState Komodo IDE 11\lib\support\php\debugging\7.2\nts-vc14-x86\php_xdebug.dll

Can anyone help me figure this out? Running Komodo IDE 11.1 on Windows 10.


#2

@mshrage_snet_net, what’s the build number of your Komodo Help > About Komodo?
Could also confirm that C:\Program Files (x86)\ActiveState Komodo IDE 11\lib\support\php\debugging\7.2\nts-vc14-x86\php_xdebug.dll exists?

  • Carey

#3

Graham got back to me and I have the correct version of php_xdebug, in the right location, and referenced in the PHP.ini file with the correct line to reference it. Whew!
Can’t ActiveState make something to check the configuration and tell us exactly what to fix and where? How about a page that says files X, Y, Z have to go A, B, C on Windows 10 to get debugging to work? Or SOMETHING???
Thanks for the reply.
Jim


#4

It sounds like you’re giving Graham different information than you’re giving me. Are you doing remote or local debugging? If it’s local you don’t need a php.ini file. If you’re doing remote debugging then I’ll need much more information.

Please answer the questions I already asked. You’re last response was not helpful .[quote=“mshrage_snet_net, post:3, topic:4609”]
How about a page that says files X, Y, Z have to go A, B, C on Windows 10 to get debugging to work?
[/quote]

These are what are commonly refered to as “the docs”:
http://docs.activestate.com/komodo/11/manual/debugphp.html

  • Carey

#5

I think there are a couple of places where issues can be posted. My issue changed in the middle as I tried to follow your suggestion and got confused as where Komodo IDE was picking up it’s php.ini and php_xdebug.dll. I decided to follow another suggestion I saw on a forum page that recommended a reset to defaults, redo the initial setup steps. Then things got very confusing when the Edit, Preferences, said local PHP debugging configuration was OK, but the Debug, Step In said it wasn’t OK.

With Graham’s help, I have it corrected now so it does local PHP debugging. However, frequently when I click the Debug->Step In, the program will just run as if had clicked Go/Continue. On a subsequent repeat with NOTHING done in between, Komodo IDE will stop on the first executable statement as it is set to do. I find it annoying that I do not get consistent response from the single step debugging operation. Any idea on what is happening?

Jim


#6

@mshrage_snet_net, So your issue now is that when you start a debug session by using Step In Komodo will start the debugger and not stop at the first executable line?

If you click Go does Komodo stop at the first executable line? I can’t reproduce this issue so there must be something else in your setup that might be triggering this. Can you think of anything unique to your setup?

-Carey


#7

So your issue now is that when you start a debug session by using Step In Komodo will start the debugger and not stop at the first executable line?

Yes - it does not stop at all as if I had clicked Go/Continue.

As I recall clicking Go/Continue runs the debugger and if there are no set breakpoints runs to the end and does NOT stop at the first executable line. This behavior is inconsistent, immediately retrying the Step In can start the debugger properly and stop at the first executable line.

Cary H - I’d like to suggest that we use TeamViewer to screen share and you can see for yourself how it behaves. Quickest most efficient way to check this out. My phone # is (removed by admin) in EST.

Jim


#8

@mshrage_snet_net, the debugger stopping at the first executable line is not a feature in local debugging. That feature is for remote debugging. If Komodo is stopping at the first executable line in your code then that’s bug.

If you could try to reproduce the issue in safe mode (Help menu > Troubleshooting > Restart in Safe-mode) then fill in the reproduction step in a bug report that would be very helpful:

As a work around you can use F5 to start the debugger rather than using the menu.

  • Carey

#9

Please don’t post your personal information to a public forum.

  • Carey

#10

I hope I posted it properly but it’s done.
Jim