License installer didn't work first time for non-admin user

Hello. I wanted to verify that, having installed Komodo IDE (version 11.1.0 build 91033) as a Windows 10 admin user, I can also run the program when logged in as a non-admin user.

So I logged out of my admin account, logged into a non-admin account, and tried to run Komodo IDE. However, it prompted me to install a license (first screenshot, attached below). So I ran my old copy of the license installer program and was told that it successfully installed the license (second screenshot). But when I then tried to run Komodo IDE, I again was prompted to install a license. I logged into my online account and downloaded a fresh copy of the license installer (third screenshot). I ran it, again was told that it had successfully installed the license, and then was able to run Komodo IDE.

Naturally I assumed that the freshly-downloaded license installer would be somehow different from the older one that I had tried at first. But the executables are of the same size and, when I used the Windows “comp” command, it informs me that the files are identical:

> comp “Komodo IDE 11 License Installer Windows.exe” “Komodo-IDE-11-Windows-S95DF591438D.exe”
Comparing Komodo IDE 11 License Installer Windows.exe and Komodo-IDE-11-Windows-S95DF591438D.exe…
Files compare OK

Anyone have any ideas as to why the first installer file works and the second one didn’t, even though they appear to be identical? Is it simply two-time’s-a-charm? :slight_smile:

Try the work around steps from this post:

Hi, Carey, and thank you for that link. It looks like my scenario is closest to that second section, and its solution steps had worked. When I get a new laptop, I’ll first try the old installer file. If it works (which would be a bit baffling) then I’ll try the second one; and if that fails I’ll simply download a fresh one.

In fact, on that completely new Win10, I intend to try all my posted Komodo IDE issues and see if any are not reproducible, which in those cases would suggest they were caused by the cruft of a Win10 that’s been altered in countless ways. Of course, I’ll update the issues with anything I learn.