Komodo12 insisting on Chrome and Xterm?


#1

Why does komodo12 insist on using Chrome web browser, also have to use xterm to
show terminal output? Was able to use Komodo without Chrome or Xterm, worked fine with Konsole(Bash) . Use Kubuntu linux


#2

Morning @BartySlarph,

I don’t believe it does. It should default to a “Komodo browser window”, so you must have changed your prefs. Edit menu > Preferences > Web & Browser.

I don’t understand what you’re asking with your second sentence. So it’s working? What needs resolving?

  • Carey

#3

When I try to run python program, Komodo says terminal program not found, install xterm. Worked fine
when first installed komodo 12, but will not work now. i have “SHELL /bin/bash” in ENVIRONMENT and when try run program brings up message about terminal. Have web broswer set to Firefox not chrome.
Also Remote Debugger settings shows Chrome extension not found .


#4

@BartySlarph,

I’m gonna have to ask you to break this into different posts. We’re not going to debug 3 different issues in one thread. Let’s stick with the shell issue in this thread. Please start new threads for the browser config and Chrome Extension issues.

For the xterm issue, please provide reproduction steps. Komodo should support Konsole and gnome-terminal as well as xterm.

  • Carey

#5

Got all the issues I had solved by not using Slate tool and Platform. Have bad Internet connection that suddenly drops out, think it too was some of the trouble. Can program in Think python on Komodo12 if I don’t try to add runtime to program with Slate. got correct terminal(Konsole), have python interactive shell. All is good for me. Thank you for the heip you gave, was able to get it working.