Komodo X - Run Config F7 hotkey changes?

Hello there!

I recently took the plunge to upgrade to Komodo X and noticed that the F7 key mapping changed. Previous, I would use F7 to run without debugging and it worked great. The python3 process starts a lot slower. But when I pushed F7, it would give me the option of picking which project configuration to run.

It looks like Komodo X replaced this with Ctrl-R, however, it just runs whatever project configuration was last used. If there any visual queue I can enable in Komodo so I can see which one will be executed? I think I’d either like a visual indicator so I can see what might happen before I push Ctrl-R, or a way to restore the previous functionality, where I can push F7, pick the config, and then let go without debugging.

In case it helps: Komodo X - Windows 7. Primarily developing in python3.

Previous was same setup, but Komodo 9.3 if I’m not mistaken.

hey @jwatkinsonrh,

My bad, thanks for reporting this. It’s a mistake in the new default keybindings and how Komodo works. The Ctrl skips the settings dialog so the default I set will skip the dialog every time. I’m fixing this right now.

You can workaround this by enabling Edit > Preferences > Debugger: Skip Debugging Options. This will invert that action.

A better fix might be to assign a new binding to it (move it back to F7?) since doing the step above will also invert the option for starting the regular debugger.

  • Carey

I lied to you @jwatkinsonrh, I’m not fixing this right this minute. I have other stuff to work on at the moment but I’ll fix this soon. I’ve filed an issue report for myself to follow up on later: https://github.com/Komodo/KomodoEdit/issues/1624

Thanks again for reporting this.

  • Carey

Not a problem at all. Your workaround is fine and I can confirm it worked, and I’m okay with both debuggers using the pop-up.

Ideally, moving it back to F7 would be nice. The new version seemed to have moved a few of the step in/step over, etc. to other keys as well. For example, F7 is now step-in, and on 9 I think it was F11?


I changed them to have those commands under one hand when running the debugger. I believe also, though It’s been a couple months since I was looking at this stuff, that I set them this way to match other IDEs that have debugging. So I want to avoid moving back to the old binding set though reordering them might…well, be in order.

BTW, you can change to the Legacy set in the key binding preferences to get all the old bindings back.

  • Carey

Understood - sounds good. Appreciate all the prompt responses and information!

No problem @jwatkinsonrh. Thanks for your question!

  • Carey