Komodo Won't start on OSX BigSur

This Library fix seems to only work if you’ve previously had Komodo installed. I’ve just installed Komodo on a (new to me) 2017 MBP 13" running BigSur; get the same error others have reported - but there is no Komodo folder in ~Library App Support, I’d guess because the app has never run.

Any suggestions? I used to use Komodo and loved it. Would be sad to move on to another editer…

HI @kbbmarch,

This doesn’t sound correct or related to this bug. If you’re getting to the point where the UI loads and then hangs indefinitely then there is a profile folder. If there is no profile folder then Komodo must not have loaded at all which would be a different issue that we should diagnose separately.

So i’m going to break this out so we don’t clutter this thread diagnosing a potentially new issue.

Can you confirm exactly what you’re seeing as an error?

Can you show the terminal output of ls -a ~/Library/Application\ Support/?

  • Carey

Thanks. Yes, I’ve proprerly installed it - is in my Applications folder - but when I open it, I get the same error everyone else has (text popup) but the application never loads. I check in Library/App Support and there is no folder for Komodo.

Screenshot attached from Terminal.

For reference, screenshot of computer overview as well.

Screen Shot 2021-03-15 at 3.14.55 PM

@kbbmarch,

Thanks for the screenshots. For more clarity, could you also provide a screenshot of Komodo at the point that it’s failing?

Could you also try, in a Terminal, running the following:
/Applications/Komodo\ IDE\ 12.app/Contents/MacOS/komodo -v

Obviously adjust the path if you’ve changed the name of the Komodo install folder.

When you do that, in the output look for anything that references a file in your profile folder, eg. mutex name:

Let me know what that path ends up being.

Two screenshots: one with that command & the error window popped up, then after closing it by clicking “OK”.

it’s failing before anything loads or opens – I just get that ‘can’t be opened’ error, and then hit “OK” or “Show in finder” which takes me to the app location. Nothing else happens.

@kbbmarch, thanks for sharing the screenshot. That is not the same issue other users are hitting. That is OSX Gatekeeper preventing Komodo from running.

^^ That should get you around your issue.

FYI, Komodo is not notarized because the Notarization system doesn’t support the version of SDK Komodo is built on on OSX. Komodo will not be updated to support it.

Trying this now. Will update.

Ok, so. Komodo opens, runs all tests/etc for what is available/installed (IE Python). Once that all completed, it locked up. I force quit/submitted report, then selected ‘no do not reopen’ (even though I had no work/project open), and same thing - locks up within a few seconds of opening.

I’ve reenabled Gatekeeper and still get the same situation - locks up within a few seconds of opening.

Progress, yes! Success, not yet. Appreciate the help.