Komodo scrolls up on autocomplete

As nathanr said i open a new thread for this problem.

I can reproduce this error on the bottom of a file. When i enter words that Komodo wants to autocomplete he scrolls up so that i can’t see what i’m writing. I have to clear the autocomplete box first.

I made some screenshots that document it:

Going to last row:

Entering “pu”

On entering the “b” for writing public Komodo wants to autocomplete and scrolls up:

Entering “return $this”:

Entering “->”:

OS is Linux Debian with Komodo Edit 9.2

  • What platform (OS) are you on?
  • Can you reproduce the issue with different files/languages?

I can’t reproduce this on Linux.

@TopSecreT, can you open a terminal and run the following command?

xdpyinfo | grep dots

You’ll get something like resolution: 108x106 dots per inch.

OS is Linux Debian Wheezy
I can reproduce it with other files for example JS or CSS.

@ervumlens resolution: 95x94 dots per inch

but i have 2 monitors don’t know which is meant by this function

@ervumlens that’s a nice trick, thanks!

@TopSecret you have a very odd DPI, a “normal” DPI is 96x96, and far as I am aware the two values tend to match each other. Could you see if your desktop environment exposes a setting to let you change your DPI? This is commonly referred to also as Text/Font Scaling. Unfortunately Komodo is known to have some issues with this on linux.

@nathanr You’re welcome! I stole it, so now you can steal it too. :wink:

Yeah, that’s an odd value. Having two monitors may complicate things too, since they may have different values.

@TopSecreT Could you do one more thing for me? Could you follow these steps and see if it fixes this autocomplete issue?

  1. Close all instances of Komodo Edit.
  2. From a terminal in your UI session, run:
    xrandr --dpi 96.
  3. Open Komodo Edit again.

This will affect one or both of your monitors’ DPI settings, but it will reset to your old values when you restart your computer.

Also, Komodo must be closed when the setting is changed or else it won’t pick up the new value.

Thanks for your replies.

I tried the setting that ervumlens suggested and after that i opened komodo again and tried it on both monitors but the issue still appears.

Maybe it has to do with the resolution? When i call xdpyinfo my resolution is 3000x1920px is that ok?

That does seem like an odd resolution. Have you checked what the max resolutions are for your monitors and see if they match up with your linux resolution?

Yes they are on their max resolution.

My left monitor has 1920x1200
My right monitor has 1920x1080 and is rotated left.

so it counts 1920 + 1080 = 3000
and because left rotation y height 1920

In version 8.5.3 the issue didn’t appear

Did running the xrandr command @ervumlens gave you change the output of xdpyinfo | grep dots?

Please check your OS settings as well; see if there is a setting related to text scaling/DPI.

Yes it gave me change in the output. But issue is the same.

I can’t find any other setting in my OS.

I think it’s not a problem of my hardware because it worked in older komodo versions.

No it’s a software problem to do with DPI settings. I don’t think the command @ervumlens suggested is properly setting the DPI. What distro and desktop environment are you using?

distro is Debian Wheezy
dektop environment XFCE

Thanks, I’ll try and find time to install a virtual machine with that configuration. Note we do not support that setup, although that doesn’t mean it can’t work, or that I won’t put in an effort to find out what’s going on.

Hi again,

i solved it!!! I found an other DPI setting in fonts setting and set it to 96. Now all works fine :slight_smile: Thanks so much for your support