Komodo reports No Perl Interpreter

I launched Komodo from the shell activated via the “state activate” command.
I setup the Perl language preferences for “Find in Path.”
When attempting to debug my project, Komodo reports that there is no Perl Interpreter.

Komodo also does not seem to find the State tool for “Run Command.”

Error Message


Perl Project Page

Launching Komodo from activate project

Morning @wblake,

That’s frustrating for you. I checked out your project myself and followed your steps. It looks like the issue is that the Komodo debugger doesn’t know what to do with a *.bat file which is what the state tool is installing for some reason.

I’d think it would install an *.exe binary but it must be doing some wrapping of the binary with that batch file. You’ll need to set your Language preferences to point at the perl.bat file. It should be in the drop down below User this interpreter.

  • Carey

Thanks. What is the Path to perl.bat? The State Tool seems to hide it.
I will make the change and see how it goes.

@wblake is it not in the drop down I mentioned?

No, just the first screenshot above that says “Find in Path.”

Oh, they should be there if you env is setup property. Here’s what it looks like for me.

[...]\Projects\Temp\Perl-5.34.0-Windows-Utilities>state activate
█ Creating a Virtual Environment for your Project's Packages

To use this project without activating it in the future, make it your default by running your activate command with the `--default` flag.
✔ Project "wilb/Perl-5.34.0-Windows-Utilities" Has Been Activated
Quick Start
• To add a package to your runtime, type "state install <package name>"
• Learn more about how to use the State Tool, type "state learn"

[wilb/Perl-5.34.0-Windows-Utilities] [...]Projects\Temp\Perl-5.34.0-Windows-Utilities>where perl

A couple things to check:

  1. Make sure Komodo wasn’t already running when you tried starting it from your CMD Window. I MUST boot fresh.
  2. Check you Preferences (and Project preferences) > Environment and make sure you’re not overriding PATH with a hard coded PATH.
  3. Try starting Komodo with ko.exe instead of komodo.exe. I can’t remember exactly what the distinction is off the top of my head but I believe ko.exe is the intended terminal command to start Komodo.

Things seem to work much better now. Thanks alot for the guidance.
The Rxtool Regex tool is very cool. Komodo Git integration appears fine. The project yaml file execution error on startup and Help/documentation preference links are the only remaining (and relatively minor) challenges.

I have a XML:Compile-SOAP Perl project to complete and also potential use for Komodo Perl Remote Debugging. And a host system change to Windows 11.

1 Like

Glad we finally got you working!

1 Like