Komodo not detecting PERL5LIB in %ENV

I’m using cpanm to install modules on perl5 running on WSL2 Ubuntu. There are some modules installed (I think default ones) under /usr/share/perl/5.30.0, and use declarations involving these work fine in Komodo on the same system.

However, cpanm is installing modules under /home/*****/perl5/lib/perl5/. This location is listed in the %ENV variable

PERL_MB_OPT="--install_base "/home/*****/perl5""                                                                    

When I try to invoke one of these modules in Komodo, as in

use Statistics::Basic qw(:all nofill);
my $c = correlation( [1,2,2], [1,2,3] );
print $c;

Komodo says “can’t locate Statistics/Basic.pm in @INC.” Yet when I run the script from the command line it works fine.

I have been getting around this by including a use lib statement, but would prefer not to have to do this. Also I installed PadWalker, which Komodo seems to want so badly, but it’s not finding that even with the use lib.

Is there some way to fix this?

@DryHeat122 are you starting Komodo from the same shell that those variables are set in?

If not, are those variables set system wide in control panel?

If not, you could try setting the additional directories pref in *Edit menu > Preferences > Languages > Perl *

I don’t know about the shell question, but I did add the directory in the suggested place and it fixed the problems. Thanks!