Komodo is stripping linefeeds from MySQL text fields

I can use phpMyAdmin to enter text in the MySQL database and all text is entered properly. When I use Komodo IDE to enter the text, it strips all linefeeds and carriage returns, but leaves other control characters. I’m using 8.5.4, build 85928. The fields I have problems with are TEXT data type. I tried changing the data type to BLOB, MEDIUMBLOB, and MEDIUMTEXT with no luck. I changed the charset from utf8 to ASCII with no luck. If I just copy the text into the field on the Komodo DB Explorer, then copy it out, the text is transformed into a single line, so it is the DB Explorer that is messing with the data, not the underlying DB code.


I tried to reproduce this, but didn’t run into the problem as yet. Which platform are you running Komodo on?

Mac OS X Mavericks. Should be easy to reproduce. Put your cursor in the field and hit enter. Instead of putting the newline in the field, it sends the data to the server. If you copy and paste a newline into the field, it just strips it out.



hello world

More info…

Doh! The field was a ‘MEDIUMTEXT’ in the database. I changed it to all kinds of things except ‘TEXT’. I’ve changed the field type to ‘TEXT’ and will hope 64k never becomes an issue.

Thanks for the report. I’ve taken a look at the Komodo dbexplorer code and it seems the mediumtext and longtext were not getting treated as text. I’ve committed a fix for that for Komodo 9.