Komodo Installation not working in Ubuntu

Hi.

I have installed both the license and the Komodo IDE on my Ubuntu 14.04 machine. However it fails to start and I have no idea why.

Here are the steps I took to install it:

./Komodo-IDE-8-Linux-x86_64-SAEE1272A9BB.executable

Message: ActiveState license installed successfully.

cd Komodo-IDE-8.5.3-83298-linux-x86_64/
./install.sh

Enter directory in which to install Komodo. Leave blank and
press ‘Enter’ to use the default [~/Komodo-IDE-8].
Install directory:

==============================================================================
Komodo IDE 8 has been successfully installed to:
/home/OGTIP/duartem/Komodo-IDE-8

You might want to add ‘komodo’ to your PATH by adding the
install dir to you PATH. Bash users can add the following
to their ~/.bashrc file:

export PATH="/home/OGTIP/duartem/Komodo-IDE-8/bin:$PATH"

Or you could create a symbolic link to ‘komodo’, e.g.:

ln -s "/home/OGTIP/duartem/Komodo-IDE-8/bin/komodo" /usr/local/bin/komodo

Documentation is available in Komodo or on the web here:
http://docs.activestate.com/komodo

Please send us any feedback you have through one of the
channels below:
komodo-feedback@activestate.com
irc://irc.mozilla.org/komodo
http://bugs.activestate.com/

Thank you for using Komodo.

I added it to the path as well but I do not seem to be able to start komodo,
Any ideas where it might be going wrong?

Thanks

Show your log.
cd /$USER/.komodoide/8.5/ -> pysterr.log

[2014-07-22 13:51:57,030] [WARNING] koSkin: Detected GTK theme via libgtk: Ambiance
[2014-07-22 13:52:06,381] [WARNING] root: ko.findresults was already loaded, re-creating it.

[2014-07-22 13:52:06,648] [DEBUG] places_js: waiting for document complete

That’s all? There are no errors.
Try to re-install Komodo and activate license AFTER installing Komodo.

done that
no cigar

How would you normaly start komodo? From the terminal?

Nope, from Applications menu.
Of course you can start Komodo via terminal with command:
{path to komodo install dir}/bin/komodo
Or if you create symlink to /usr/bin/ you can just type “komodo” and it start.
To create symlink in your case:
ln -s /home/OGTIP/duartem/Komodo-IDE-8/bin/komodo /usr/bin/

nope none of the 2 options work

Try to install to another folder…
Also try to run komodo via sudo.
sudo /home/OGTIP/duartem/Komodo-IDE-8/bin/komodo
sudo /opt/komodo/bin/komodo
I think you don’t have permissions to run Komodo (lol).

I already tried that …

I tried installing it on /opt/komodo

Also did not work!

Very strange…
Your log doesn’t show me some errors and it’s just doesn’t run. I hope it’s not a Ubuntu glitch.
So we cast some staff…
cast @nathanr

I do have permissions RWX.

/home/OGTIP/duartem/Komodo-IDE-8/bin

lrwxrwxrwx 1 duartem domain users 21 Aug 1 10:36 komodo -> …/lib/mozilla/komodo

but you are rigth…

It does start if I use sudo!

What can I do to fix this?

O_o
Try this
sudo chmod 755 -R /home/OGTIP/duartem/Komodo-IDE-8/

well… I fixed it … very odd
when I first installed it , it would not start and not give any message
I then used sudo and it started but it did not recognized that I had already installed the license…

So i executed the license installation with sudo

I was then able to start komodo with sudo

Then I tried starting it without sudo

and I got this message:

komodo: error: error creating '/home/OGTIP/duartem/.komodoide/8.5': Permission denied
komodo: error: could not determine the user data dir

so I changed the permitions to the ‘/home/OGTIP/duartem/.komodoide/8.5’ folder and now I am able to start komodo
form my normal user

My congratulations!

Do you think there is some bug on the installation or is this something only affecting me?

It’s only your problem. Or it’s Ubuntu problem. Not Komodo problem.
In Debian (Ubuntu based on Debian) I doesn’t get this problem never. But this can caused by I’m installing all programs via sudo (just for don’t get some problems with chmod after) :smile:

Sounds like you had a permission issue of some sort either on your profile or install folder (or both).

If this happens again try starting Komodo from your terminal as some errors will not end up in your pystderr log and will be directly printed to stdout. Additionally you can use the ‘-v’ flag to run Komodo in verbose mode, eg. komodo -v.