Komodo IDE X becomes slow after a few hours


Me and my colleague are using Komodo IDE 10 for Perl development. For both of us, there seems to be some lag after Komodo has been running for an hour or two. For example when clicking at another line, it may take up to a second for the cursor to actually move there. The lag is gone after restarting Komodo IDE, but will eventually appear again. Usually I have to restart Komodo two or three times during my work day.

Often we have a lot of files open in Komodo, but I am not completely sure if this is directly related to this problem. Most of the time the amount of open files stays about the same, but the lag still appears.

Here is a memory report when the lag starts to appear:

And for comparision, a memory report from after restart:

Processor : 4x AMD FX™-4170 Quad-Core Processor
Memory : 8141MB
Operating System : Ubuntu 14.04.5 LTS

Komodo IDE, version 10.1.3, build 89510, platform linux-x86_64. Built on Tue Nov 29 15:10:27 2016.



We initially moved from Eclipse + EPIC to Komodo IDE because Komodo IDE was much better for programming with Perl. But with the new version 10.* we have had issues firstly with performance, but also the module autodiscovery has broken as well. Meaning we cannot autocomplete the subroutines of known objects or other loaded modules, even through static referencing.

Hi @lari, thank you for the memory reports. We’ll have a look.

@nathanr: you are more familiar with Komodo’s innards than me, perhaps you can glean where a memory problem might be? The window and add-on memory usage seems a bit high to me, but I wouldn’t know what is causing that.

Hi @kivilahtio, if you have a concrete case where you’re experiencing a failure, please file a bug with all of the information, steps to reproduce, etc., and we’ll look into it.

Hi @lari, I have observed this problem myself on a few occasions, it is something we’ll be working towards fixing over the coming releases but it may not be a “one silver bullet” type of problem. I don’t have a solution for you right now (restarting would be the most appropriate workaround). You could also use “Tools > Addons (Legacy)” to disable any addons you’re not using.

Please let us know if you notice some type of consistency in when the slowdown starts happening.

Apologies for the inconvenience.