Komodo IDE unit-testing feature request/bug

When using a virtualenv and python, the default points to the system installation (ex c:/python36/python.exe) instead of the virtualenv (ex C:/Users/devdave/Desktop/projects/projectName/env/Scripts/python.exe).

I checked and this is also present in Komodo. The command line assist icon is present for making a custom command but the %(python) shortcut/macro isn’t listed. Since this is generally a one time problem and there is a solution, this is probably a low priority.

An adjacent issue is that I couldn’t find a means for submitting a bug/feature request for Komodo IDE exclusive components like unit-testing.

Hi, I can only comment on your latter issue, and that is that you also use https://github.com/Komodo/KomodoEdit/issues for IDE-only issues. We’ll tag as appropriate. Thanks.

This is not a bug, Komodo uses the environment variables it is started with. No additional virtualenv detection mechanism exists at the moment. You have to manually configure it via Preferences > Environment.