Komodo IDE scrolling issue


#1

I am trying to use regular expressions in Perl in Komodo 12, but it causes my current file scrolling issues. After writing a following statement

$test =~

… I am suddenly no longer able to scroll to top of the file.

I looked if something is getting written into log files ~/komodoide/12.0 but found nothing except codeintel attempting to get completions.

See screencast:

Ubuntu 18.04
Komodo IDE, version 12.0.1, build 91869, platform linux-x86_64. Built on Mon Feb 10 19:37:24 2020.
This is perl 5, version 26, subversion 1 (v5.26.1) built for x86_64-linux-gnu-thread-multi
(with 67 registered patches, see perl -V for more detail)
Using 4k screens with 200% scaling.


#2

Morning @komodo

That is bizarre. I tried to reproduce this myself and can’t. I have a similar screen setup as well though I’m on Windows. Are you able to use your keyboard to get back to the top of the file? What happens if you close and open the file? I assume this is 100 reproducible for you?

Could you try reproducing in Safe mode? Help menu > Troubleshooting > Restart in Safe Mode.


#3

I can’t use keyboard to go to the top.

Reopening the file works but the problem occurs as soon as I use regexes again.

Yes it also happens on safe mode.

I also tried changing my resolution to full hd, it still occurs.

I also tried it in a simple text file (via New file), it still occurs when I type the tilde ~ character. It appears it has nothing to do with regexes. Simply typing ~ reproduces it. I noticed the ^ character also reproduces the problem. Also the ´ and ` characters. And ¨. The similarity with these characters is that at least in the Nordic keyboard I have to press the key twice to get this character.

SHIFT + ¨¨ = ^
ALT GR + ¨¨ = ~
´ (two key presses to print the character)
SHIFT + ´´ = `
¨ (two key presses to print the character)

If you have any characters in your keyboard of which key you must press twice to print it, try it out.

When I try to see which keyevent keycode it is via this JS tool https://unixpapa.com/js/testkey.html it simply says 0
keydown keyCode=0 which=0 charCode=0
keyup keyCode=0 which=0 charCode=0

I also tried in Komodo IDE 11, it’s reproducible there as well.


#5

The issue seems to be the 200% scaling.

When I reverted it back to 100%, it works.


#6

@komodo,

Are you certain third party software isn’t involved here? Something special when you hold shift and press a button twice? It wouldn’t expect a 3rd char to be printed, I’d expect two of the “shifted” keys I pressed.

  • Carey

#7

No it’s standard behavior in Nordic layout.


#8

Morning @komodo,

Could you file a bug. I’d do it but this is the first I’ve heard of a dead key and can’t reproduce the issue so I’d probably miss something.

Be sure to link back to the forum post in the ticket.

  • Carey