Komodo IDE freezes upon start


I am using the current version of the IDE in the evaluation period. Sadly, since two days, each time, when I start up Komodo, it freezes after the GUI has fired up. I need to kill it after that. Before it went all fine.

I am on Windows 7 Home Premium, 4GB RAM, Nvidia gfx, Core i3. ko.exe is (

The only thing I remember changing in my system was installation of “ConEmu” a replacement terminal window, that offers options to patch itself a bit deeper into the system (it tries to catch other app’s console launches and redirect it into its own terminal window. Now, upon start, the IDE opens with the lower pane open, and it opens right with the output console. Could it be that? I remaned the folders, where ConEmu is installed (I got both 32bit and 64bit variants installed), tried to unregister all handlers it uses, before, but to no luck. And yes, I rebooted the system. Any ideas? It would be nice if I could use the last three days of eval, since I did not advance much, and IDE is a powerful beast, so evaluation takes its time.

Thank you,

Show for us “Help - Troubleshooting - View Log File”.

No can do. The UI is blocked. :wink:

But I tried something else: I started it with “–verbose” from the CLI. I forgot to say, that it shows exactly one dialog, the one you will see in the attached screenshot in illustration no.1. Independant from which option I chose in the dialog, I get the same behaviour. The last line here: “Zugriff verweigert” means “Access denied”. It is interesting to note, that it hunts down the C:\Cygwin\Python path in the beginning, though I have set C:\Python27 in my %PATH%, which is the ActiveState version, btw. Currently I have no idea, why the system would do that.

In illustration no.2 you can see the output in the console. This goes on forever and forever (hence the UI freeze, I guess). It just spills the same text over and over, I had to screenshot it, since it would not let me mark&copy the text, since it was constantly dumping the same text and scrolling. Thanks.

Find in your system file pystderr.log and attach it to your message. It’s can say much more for @toddw, @nathanr.

Okay, find it linked as zip archive. Beware, the extracted file is over a 9 MB in size. I tried to keep it small by acting as quick as possible, but couldn’t make it smaller (the one before was over a 100 megs).

Thanks, Andreas

P.S. Resetting the preferences to default solves the issue for now.

It’s because Komodo cannot execute any external processes anymore - probably due to the ConEmu that got installed? So it’s now borked at startup.

Try uninstalled ConEmu. There may even be a way to use both - maybe something to do with the comspec environment variable?

I did the following:

First I reset the configuration, as stated above. That way, all was fine. But I did not open the command output window in the lower pane, since I thought, that may be the problem, as long as ConEmu is being present.

I then uninstalled ConEmu, rebooted and tried Komodo with the console output pane open. All fine. No problems. Quit Komodo. Now I reverted to the old configuration, bummer: Same problem happened, though ConEmu has been uninstalled. Could it be, that it left something behind? I don’t know. This is over my capacity to check. However, I am fine now with the reset configuration, as I have it now. Thanks.

Only thing I could think of is if you changed the Komodo Environment preferences, which affectly the ability to launch subprocesses - e.g. the COMSPEC environment variable.

I’m glad you have a working Komodo back.