Komodo IDE 9.3.0 - Workspace with wrong tab order

In Komodo IDE 9.3.0 the Workspace don’t save the tab order in the correct way.
After restart the tabs are sort by name or file extension.
But in Komodo IDE 9.2.0 it’s works correct. The user sorted tab order were saved and restored.

Is there as solution to get the preview behavior?

I think you are probably getting confused by Komodo 9.3’s new feature where it sorts your tabs according to your Open Files, open your left panel and go to the Open Files pane, then hit the cog icon and uncheck “Sort Tabs”.

Unchecking “Sort tabs” in Open File pane works, but there should be an option to uncheck “Group tabs”. As I want my files to be grouped in Open File pane, but not in tab bar.

To hint the cog icon in Open Files pane to uncheck “Sort Tabs” is rigth.
That would be the behaviour i want.
But it doesn’t works.
I think there is a bug in Komodo IDE 9.3.0.
Komodo always sort the Tabs although the “Sort Tabs” option is unchecked.
The right behaviour should be “Group tabs” in Open File pane and not change the tab order if “Sort Tabs” unchecked.

After Komodo restart option “Sort Tabs” always checked.
How to fix this bug in v.9.3 ? (previous versions don’t have this bug)

Have the same problem here. After a restart of Komodo, “Sort Tabs” is checked again.

But even when i uncheck it, there are instances when Komodo still sorts some of the tabs.

Please report it on our bug tracker: https://github.com/Komodo/KomodoEdit/issues

Opened a bug for this here (including workaround): https://github.com/Komodo/KomodoEdit/issues/841

That’s likely just the default tab ordering (ie. the way tabs are opened), Komodo does not do any tab sorting other than the one specified in the Open Files pane.

The issuse 841 works.
But if you want to insert a new tab in the custom tab order, Komodo sort the tabs although “Sort Tabs” is uncheck.
For instance to sort in an Browser Preview.
If “Sort Tabs” is uncheck Komodo should not sort tabs anymore.

That is what the issue is about, please check the workaround posted on github.

I have checked the workaround. I have run the command:
require(“ko/prefs”).setBooleanPref(‘openfiles_tab_sorting’, false);
I have still the problem when i insert a new tab in my custom tab order.
Is there anything more which i have to do?

By the way. A Browser Preview tab is not saved in the Komodo Workspace and not restore after a restart.
The Browser Preview tab is missing where all other tabs are correct restored.
Is there any reason for this behaviour?

We just released Komodo 9.3.1 which fixes this bug, download it from our website and you should be good.

I don’t believe browser previews are currently taken into account. Please consider logging an enhancement request:

Thank you! The new release Komodo 9.3.1 works correct.
:slight_smile:
To the problem with the Browser Preview tab i have create a new issues.
Browser Preview not taken into account #892.