Komodo IDE 9.0.1, So slow on Linux

I am running Komodo IDE 9.0.1 build 87208, platform linux-x86_64 on Centos 6.5.

About 2 weeks ago, the editor and debugger has slowed down. The syntax check takes about a minute to respond. The debugger takes a long time to startup.

I am running a powerful system: 32GB memory, 8 cpu @ 2.4Ghz.


Hm, anything in your log and memory usage stats? (Help - Troubleshooting - View log file / Memory Usage)

Are you working with a mounted remote drive by any chance?

You could try disabling Editor > Detect when networked files are changed outside of the environment preference to see if that helps.

  • Carey

Here is my part of my logs the warning repeat many time throughout the session:

Application Basics

Name: Komodo IDE
Version: 9.0.1
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 KomodoIDE/
Multiprocess Windows: 0/3

Crash Reports for the Last 3 Days

All Crash Reports


Adapter Description: X.Org – Gallium 0.4 on AMD TURKS
Device ID: Gallium 0.4 on AMD TURKS
Driver Version: 2.1 Mesa 10.1.2
GPU Accelerated Windows: 0/3 Basic
Vendor ID: X.Org
WebGL Renderer: X.Org – Gallium 0.4 on AMD TURKS
windowLayerManagerRemote: false
AzureCanvasBackend: cairo
AzureContentBackend: cairo
AzureFallbackCanvasBackend: none
AzureSkiaAccelerated: 0

Important Modified Preferences

browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size_cached_value: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
extensions.lastAppVersion: 9.0.1
network.cookie.prefsMigrated: true
places.history.expiration.transient_current_max_pages: 104858
plugin.importedState: true

storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1428761610

Important Locked Preferences


Incremental GC: true


Activated: true
Prevent Accessibility: 0

Library Versions

Expected minimum version: 4.10.7
Version in use: 4.10.7

Expected minimum version: 3.17.2 Basic ECC
Version in use: 3.17.2 Basic ECC

Expected minimum version: 3.17.2 Basic ECC
Version in use: 3.17.2 Basic ECC

Expected minimum version: 3.17.2 Basic ECC
Version in use: 3.17.2 Basic ECC

Expected minimum version: 3.17.2
Version in use: 3.17.2

Experimental Features

Here’s a snapshoot of top while I am editing Perl code. I am not running Perl or Python programs.


I don’t currently have any remote drive mounted. The code files are on the local drive in Git repositories.

I am running IBM’s BigFix Client.


Try turning off Syntax Checking and see if that helps, Edit > Preferences > Syntax Checking.

It looks like you’ve got a run away Perl process.

If that doesn’t help could you do Defmans suggestion of giving us the Memory Usage measurements provided by Komodo?

  • Carey

The performance is the same without Syntax checking.

I am unfamiliar with Defmans.


@defman is one of our community member who suggest a step for you to try.