Komodo IDE 8.5.3 under Ubuntu 12.04: installing license not working


I’m on Ubuntu 12.04 with Komodo Ide 8.5.3 installed 2 weeks ago.
Today was my last day from the trial period and I decided to buy it and bought it.
After changing the rights to the …executable file I manage to run it with:
in terminal and got this result:
ActiveState license installed successfully.

But when I try to start Komodo get this:
“Thanks for choosing Komodo IDE. Your trial period has ended…”
What do I need to do to activate it?


EDIT: I used to start it from terminal with root privileges and everything seems to be fine, but is there a way to start it from Application menu?
It’s not pleasant every time to start terminal in order to start the Ide, and if I close the terminal by mistake, the Ide will die.

If you are run Komodo by root - you must activate your license as root. (sudo ./Komodo-IDE-8-Linux-x86-<licenseID>.executable).

To run Komodo with root priv-s you must edit /usr/share/applications/komodo-ide-8.desktop, line Exec= (insert sudo before path to komodo file and if sudo ask you a password: change Terminal=false to Terminal=true.).
But you can edit /etc/sudoers if you don’t want type password when run komodo by root.
Insert/edit line after root ALL=(ALL:ALL) ALL:
<USERNAMEHERE> ALL=(ALL:ALL) NOPASSWD: ALL and save it (you must edit this file by root!)
If you did this, you must change Terminal= in komodo-ide-8.desktop to false.

I manage to start it like normal user from the menu with just starting the licencing file as normal user.
This way I got back all my key binding, color and font settings from the time I was evaluating the Ide.
I’m not sure if this will cause a problem in future, do I need to uninstall in some way the first one installed as sudo?

Thanks for the help!

Sorry, I don’t understand you properly.
When you installing Komodo - you just install a program. You can run Komodo as root or as user. If you run it as root - program will not be edited by you. If you run it as user - program will not be edited by you too. When you run Komodo - Komodo will create profile in ~/.komodoide/8.5/ (in your case).
Let’s watch on this in more details:

  1. You run Komodo as sudo - you run program as root and it’s create folder .komodoide/8.5/ in /root/.
  2. You run Komodo as user - you run program as base user and it’s create folder /home/<username>/.komodoide/8.5/.

Please don’t run Komodo as root, there’s really no reason you’d ever want to do that.

Make sure you run the license installer as your own user (no sudo). Since it seems like you may have ran Komodo as root you may want to move over your profile from root to your user, your profile folder is located at /root/.komodoide for the root user and /home/<username>/.komodoide for your own user. I’d recommend making backups before messing around with those folders. You should also run a chown on your profile directory to ensure the file permissions are set correctly.

This is exactly what I did the second time. I don’t want to run Komodo as root.
Just the first time I run the licence installer I was logged as root in the terminal. This was the mistake.

Thanks both for the explanation!

Sure thing, and thank you for responding. As a direct response we’re adding in a warning for when someone tries to run Komodo (or the installer) as root.

:frowning: Please add disabling for this waring.

It’s a warning, you can choose not to listen to it. We won’t add disabling for a warning, disabling = not listening (which you shouldn’t do).

If you need to run Komodo as root you should probably re-think your setup,