Komodo IDE 12 requires authorization every start


#1

Starting from version 12, the Komodo IDE requires authorization every time you run the program. (Version 11 (with last updates) did not have this problem - after installing 1 time logged in and that’s all, then there are no problems).
%D0%B8%D0%B7%D0%BE%D0%B1%D1%80%D0%B0%D0%B6%D0%B5%D0%BD%D0%B8%D0%B5
This disaster is present on different computers with different versions of Windows x64 (v7, v10).
I don’t need any ActiveState Platform - it interferes with me, I need to work without the Internet.
How do I disable all authorizations and work offline???
Please help me!
PS: Komodo IDE 12.0.1.build 91852


#2

@Vladislav,

I’m not able to reproduce this. I’m running the 91852 nightly and haven’t had to login at all.

Let’s figure out what’s going on with your machine.

  1. Please confirm the build you’re running in Help > About Komodo.
  2. What OS and vesion are you running?
  3. After reproducing the issue, send your logs to careyh@activestate.com
  • Carey

#3
  1. Komodo IDE, version 12.0.1, build 91852, platform win32-x86.
    Built on Wed Jan 29 10:47:04 2020.
  2. MS Windows 7 Home Premium 64-bit SP1
    MS Windows 10 64-bit
  3. sent to careyh@activestate.com

#4

Morning @Vladislav,

Thanks for sending your logs. It’s not clear what’s wrong from those logs.

I’m going to get you to run a couple commands to get more info. First open the JS Console: View > Tabs & Sidebars > Console

Then run the following commands but DO NOT post the returned info here. Email it to me. There will be private information in some of the output:

require("ko/auth").authenticated((bool)=>console.log("Authenticated: "+bool)) // should eventually print 'true' to the console.  It can take a few second to complete
console.log("Installed: " + require("state/tool").installed()) // should print 'true' to the console
console.log(require("ko/auth").getCredentials(require("ko/auth").apiKeyUrlForPWM).password) // private info
console.log(require("ko/auth").getCredentials(require("ko/auth").userUrlForPWM).password) // private info
console.log(require("ko/auth").getCredentials(require("ko/auth").privkeyUrlForPWM).password) // private info
console.log(require("ko/auth").getCredentials(require("ko/auth").totpUrlForPWM).password) // private info.  If this one fails I'm not worried, unless you have two factor authentication enabled on the Platform
ko.prefs.setBoolean("state.verbose.unsafe", true)

Put the output from the above commands into the email you’ll send to me then do the steps below as well:

  • Restart Komodo and log in again
  • open the JS console again and run the following command: ko.prefs.setBoolean("state.verbose.unsafe", false)
  • Grab the log file and add it to the email.

The pref command enables some additional, unsafe logging (it will dump private info to your logs) which might help us figure this out. Once Komodo starts up and you’ve logged in we’ll have the logs we need and you can disable the pref (which is step two above).

  • Carey

#5

sent the results by e-mail


#6

Hey @Vladislav,

Looks like the state tool is failing to install for you for some. Try manually installing it then starting Komodo:
http://docs.activestate.com/platform/state/#installing-the-state-tool

  • Carey

#7

Did you read my first message?
I don’t need extra tools, they make it difficult to work, they make Komodo worse.
Komodo has become very heavy and slow, and any of extra tools that can not be turned off - this is a great evil.
How can I disable the state tool?? This state tool brings people problems


#8

Hi @Vladislav, you shouldn’t need the state tool. I’m trying to figure out why you’re getting repeat logins. Please try what I suggested.

Also, do you have an antivirus program running other than Windows Defender?


#9

No, there are no antivirus programs on all my computers (computers have different configuration, different versions of Windows x64, but the problem is the same everywhere).
PS: specially checked computers for viruses with a scanner (and I do it regularly) - everything is absolutely clean


#10

@Vladislav, Thanks for confirming.


#11

@Vladislav,

Can you do one more thing for me? Run dxdiag /t outfile.txt in a Cmd Prompt and email me that resulting outfile.txt.

Btw. tomorrows nightly will have a fix for the repeat login issue. Whether or not the state tool is installed, you will not be asked to log in again.

  • Carey

#12

What wonderful news!!!
Сan you tell how to disable all unnecessary features and make Komodo lighter and faster?
For example, the Komodo IDE consumes 260 MB of RAM, but still runs pyton.exe (25 MB + cmd.exe 2.5MB) and Powershell (65 MB + cmd.exe 2.5MB). Why do the last two eat away the memory?


#13

Morning @Vladislav,

You can try these steps to increase performance of Komodo:
https://community.activestate.com/faq/how-improve-komodos-editing-performance.

FYI, you’re not going to do much better than 260MB of RAM. The Python process is code intelligence. It runs out of process so it doesn’t slow down the Komodo process.

The Powershell process is what I suspected is going on re: state tool. Komodo is attempting to install the State Tool which occurs in the Powershell subprocess. It looks it’s hanging for some reason. If you could try manually running the install command in a CMD Prompt it might tell us why so we can prevent it from happening:
powershell "IEX(New-Object Net.WebClient).downloadString('https://platform.activestate.com/dl/cli/install.ps1')"

  • Carey

#14

@Vladislav,

One more thing (hopefully last thing). Could you also run the following in a Powershell terminal and share the output. The output can be shared in this thread.

Get-Host | Select-Object Version

Also, thanks for the output from dxdiag.

  • Carey

#15
  1. Thank you so much for updating Komodo - it no longer requires you to log in constantly
  2. About manual install state tool: Powershell couldn’t do it:

Blockquote
C:\Users\User>powershell “IEX(New-Object Net.WebClient).downloadString(‘https://platform.activestate.com/dl/cli/install.ps1’)”
ПРЕДУПРЕЖДЕНИЕ: x86 processors are not supported at this time
ПРЕДУПРЕЖДЕНИЕ: Contact ActiveState Support for assistance
ПРЕДУПРЕЖДЕНИЕ: Aborting installation
1

I have x64 version Windows:
Operating System: Windows 7 Home Extended 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_ldr_escrow.200102-1707)
What is wrong?

  1. Powershell terminal:
    PS C:\Users\User> Get-Host | Select-Object Version
    Version

2.0


#16

Permanent login prompt does not depend on State tool. I checked this on a Windows 10 computer: State tool installed, but Komodo requests log in every start:

Thank you for solving the problem with a permanent login


#17

One question: why do I get this message after every regular update of Komodo (Help -> Check for updates) on all my different compueters:
%D0%B8%D0%B7%D0%BE%D0%B1%D1%80%D0%B0%D0%B6%D0%B5%D0%BD%D0%B8%D0%B5
…and my workspace is lost: the current project is disabled, opened files disappearing? I get only one tab: “New tab”.
Why regular update can’t shutdown Komodo cleanly and can’t restore files and projects from my session?


#18

@Vladislav
Thanks a lot for all that debugging information! That explains things. The state tool can’t be installed with Powershell 2. If you come around to using it you can try upgrading Powershell to 3.

Re: the update. I’m not sure why that’s happening, sounds like a bug. If you open your project it will open your files, unless you disabled that (Edit menu > Preferences > Workspace > Project Management: When opening a project…).

I’ve filed a ticket for this but given it’s nature, a fix in the next release will have no effect on currently installed version, where the bug is: https://github.com/Komodo/KomodoEdit/issues/3838

  • Carey

  • Carey