Komodo IDE 12 is Now Available.. for FREE!

Komodo IDE is now free! Version 12 may not pack a ton of new features, but it is completely free.

Get your copy now!

Aside from it being free this release also adds more integration with the ActiveState platform. This will provide you with the following functionality:

  • Virtualized runtime environments, don’t worry about your project dirtying up your systems language install
  • Dependency management through the ActiveState Platform
  • Script & Secret management, using your runtime environment so anyone contributing to your project can easily run the same scripts

To find out more about the new integration and what it enables you to do check out our documentation.

Besides the new ActiveState platform integration this release includes a ton of bug fixes, check out our release notes.

We will post a more detailed announcement later next week on our blog, so stay tuned if you want to learn more!

1 Like

Hi everyone!

If you’re one of the few that has had issues starting Komodo please try the nightly here and you’ll be up and running.

Thanks!

  • Carey

Hi - I’m a long-time Komodo Edit user excited by this news, but the Linux (x86_64) link at https://www.activestate.com/products/komodo-ide/download-ide/ just resolves to a page displaying what looks like an IP address.
Is there a valid 64 bit Linux package somewhere?

Thanks!!

Edit: 5 minutes later this link is working perfectly. Maybe it was a temporary problem, or that’s a seriously quick response!

1 Like

@agt, Pretty sure it was magic that fixed it!

  • Carey

The world needs more magic, so keep it coming.
Thanks for the work of your mortals in the team too.

1 Like

Its great to see that Komodo IDE is now free. However, has it been open-sourced?