Komodo IDE 12 consumes 100+% CPU

Back on Komodo IDE 12 now after having reverted back to 11 for some time. One of the issues I see with Komodo IDE 12 is that it runs on very high CPU usage sometimes. I always have the IDE open with a few tabs that I use frequently.

Right now I’m not using the IDE but it still runs on 60% CPU. I was actually not using the computer at all earlier and just went here because the fan span up and was making a lot of noise - the IDE was then using 114%. It has dropped to 60% now while I was browsing the forum to see if there was any similar issues reported.

I tried to follow the guide here to get some profiling info, but I think this guide requires some prior knowledge that I don’t have. http://docs.komodoide.com/SDK/How_to_profile_Komodo

I did start and stop the profiler with



I typed it in the Console in the editor. Was that right? I haven’t been able to find the log anywhere.


Profiling results are saved to the β€œprofiler” folder within your Komodo profile folder.

From the docs link above.

You could also checkout Help > Troubleshooting > Memory usage.

I’d also try going through the prefs and disabling things like Code Intel, Syntax checking and Source Code Control.

Not sure what OS you’re using, sounds like OSX if it’s reporting β€œ114%” CPU usage. I know Windows makes it pretty straight forward to see subprocesses of a process, maybe theres is a way to do that on OSX as well?

My Komodo is currently running at 0.9% CPU so at least we can guess that it’s something unique to your setup that might be causing the issue.

  • Carey

Yes, this is a Mac. Running OSX Catalina 10.15.4

Profiling results are saved to the β€œprofiler” folder within your Komodo profile folder.

Yes. Once I realized this was a Mac I found the profile :wink:
It’s 163Kb zipped. Do you want it?

Looking at β€œtop” I could only find one child process to Komodo, a python running pylib/codeintel/lib/server.py but that process stays at 0% CPU. It’s the main process that’s constantly at 45-60% CPU up to 100+% whenever the window is active.

The β€œActivity Monitor” displays a counter for mach system calls which is increasing steadily with 100-200 calls every five seconds. Not sure if this is expected, but seems like a waste of resources for an idle application.

I tried to disable code intelligence but the IDE stopped responding completely. I had to kill it. I restarted the IDE now. It stays around 6-7% without any files open. I think it has to be open for a day or two before this happens.

… 24 hours later …

Haven’t touched the IDE since yesterday, it’s open with two local files loaded. I see that it regularly jumps up to 35% CPU usage but then a few seconds later go back to < 1%. What kind of runtime is Mozilla running on? Is there a GC or JIT that runs periodically?

I’ll get back to this thread if it runs up to 100+ again.

This can of course be something specific to my environment but I don’t have any special settings as far as I know so I’d assume that I’m not the only one experiencing this. It could be that most users don’t leave their IDE open 24x7. :slight_smile:

Another day has passed and I haven’t touched the IDE today either.

Now it hovers around 60% CPU usage. It sometimes dropps to 10-20% but after a few seconds it goes back to around 60%.

You asked about memory usage earlier. Below is the top level view of the usage tree. 345MB is a decent piece of memory but there is plenty free on the computer still. The main process is said to have 934MB allocated if you ask the Activity monitor, so I guess the comment in the IDE is correct, the β€˜explicit’ tree seems to show less memory than it should. (Apparently the β€˜heap-allocated’ memory reporter doesn’t work on Mac.)

Explicit Allocations

345,094,946 B (100.0%) -- explicit
β”œβ”€β”€118,446,200 B (34.32%) ++ js-non-window
β”œβ”€β”€β”€93,931,848 B (27.22%) ++ window-objects
β”œβ”€β”€β”€49,899,280 B (14.46%) ++ gfx
β”œβ”€β”€β”€18,621,392 B (05.40%) ++ add-ons
β”œβ”€β”€β”€16,363,520 B (04.74%) ++ cycle-collector
β”œβ”€β”€β”€16,281,632 B (04.72%) ++ xpconnect
β”œβ”€β”€β”€15,084,832 B (04.37%) ++ workers/workers(chrome)
β”œβ”€β”€β”€β”€4,792,626 B (01.39%) ++ startup-cache
β”œβ”€β”€β”€β”€4,345,072 B (01.26%) ── spell-check
β”œβ”€β”€β”€β”€2,635,120 B (00.76%) ++ storage/sqlite
β”œβ”€β”€β”€β”€1,540,288 B (00.45%) ── xpti-working-set
β”œβ”€β”€β”€β”€β”€β”€764,208 B (00.22%) ++ atom-tables
β”œβ”€β”€β”€β”€β”€β”€535,856 B (00.16%) ++ xpcom
β”œβ”€β”€β”€β”€β”€β”€463,728 B (00.13%) ++ layout
β”œβ”€β”€β”€β”€β”€β”€306,576 B (00.09%) ── preferences
β”œβ”€β”€β”€β”€β”€β”€232,736 B (00.07%) ── icu
β”œβ”€β”€β”€β”€β”€β”€198,544 B (00.06%) ── script-namespace-manager
β”œβ”€β”€β”€β”€β”€β”€196,608 B (00.06%) ── dom/event-listener-managers-hash
β”œβ”€β”€β”€β”€β”€β”€167,760 B (00.05%) ++ images
β”œβ”€β”€β”€β”€β”€β”€132,848 B (00.04%) ── cookie-service
β”œβ”€β”€β”€β”€β”€β”€β”€89,520 B (00.03%) ── telemetry
β”œβ”€β”€β”€β”€β”€β”€β”€60,400 B (00.02%) ++ network
β”œβ”€β”€β”€β”€β”€β”€β”€β”€4,352 B (00.00%) ── history-links-hashtable
└────────────0 B (00.00%) ++ media

Other Measurements

34,107,392 B (100.0%) ++ decommitted
7,162 (100.0%) ++ event-counts
167,760 B (100.0%) ++ images
162,889,856 B (100.0%) ++ js-main-runtime
342 (100.0%) ++ js-main-runtime-compartments
120,283,136 B (100.0%) ++ js-main-runtime-gc-heap-committed
39 (100.0%) ++ message-manager
1,590 (100.0%) ++ observer-service
883 (100.0%) ++ observer-service-suspect
565 (100.0%) ++ preference-service
68,109,584 B (100.0%) ++ window-objects

            0 B ── canvas-2d-pixels
           68 B ── gfx-surface-quartz
            0 B ── gfx-textures
            0 B ── gfx-tiles-waste
              0 ── ghost-windows
              0 ── host-object-urls
            0 B ── imagelib-surface-cache
      393,216 B ── js-main-runtime-temporary-peak
          3,402 ── page-faults-hard
     20,786,407 ── page-faults-soft
  901,361,664 B ── resident
8,205,340,672 B ── vsize

This sounds more serious then high CPU usage and perhaps telling. What exactly did you disable? At what point did Komodo freeze?

Did you try disabling the other features I mentioned?

This sounds more serious then high CPU usage and perhaps telling. What exactly did you disable? At what point did Komodo freeze?

I disabled all β€œFeatures” in Code intelligence: Completions, Calltips, Symbol list, Symbol browser, scanner, Go to definition, Jump sections, and Find references.

I believe it froze when I hit Apply. Unfortunately I’m not 100% sure about that, it could have been when I hit OK as well, to close the preferences window. I have experienced crashes when exiting the Color scheme editor as well. I’ll be more observant going forward and take note of exactly at what point this happens the next time.

I have not tried to disable Source control or syntax checking yet. I’ll do that the next time I see high CPU usage. Currently I don’t see any problem but I restarted the IDE yesterday.

1 Like