Komodo IDE 11 - Toolbox widget unable to load. Component returned failure code


I’m a reasonably long time Komodo Edit user who decided to give the Komodo IDE 11 trial a go. However, I’m finding that Komodo IDE isn’t loading the toolbox widget so I can’t add any commands to, for example - run the script through python. I checked my pystderr.log and found this exception:

 [2017-10-03 10:54:04,637] [WARNING] keybindings: [Ctrl+0] was used for 'cmd_goToQuickBookmark_0', overriding to use 'cmd_fontZoomReset'
[2017-10-03 10:54:05,296] [DEBUG] ko.launch: versioncheck on http://docs.komodoide.com/changelog/11
[2017-10-03 10:54:05,572] [INFO] koInitService: Adding pre startup service for 'koFileStatusService': '@activestate.com/koFileStatusService;1'
[2017-10-03 10:54:06,040] [INFO] komodospellchecker: Spell checker loaded.
[2017-10-03 10:54:06,042] [INFO] komodospellchecker: Using dictionary en-US
[2017-10-03 10:54:06,167] [INFO] elastic_tabstops: Elastic tabstops loaded.
[2017-10-03 10:54:06,243] [INFO] codeintel/process: Starting CodeIntel
[2017-10-03 10:54:06,246] [DEBUG] codeintel/process: PYTHONPATH: C:\Program Files (x86)\ActiveState Komodo IDE 11\lib\python\..\lib\python2.7;C:\Program Files (x86)\ActiveState Komodo IDE 11\lib\support\dbgp\pythonlib;C:\Program Files (x86)\ActiveState Komodo IDE 11\lib\mozilla\extensions\codeintel@activestate.com\content\..\pylib\codeintel\lib;C:\Program Files (x86)\ActiveState Komodo IDE 11\lib\mozilla\extensions\codeintel@activestate.com\content\..\pylib\codeintel\env\Lib\site-packages
[2017-10-03 10:54:09,170] [ERROR] koToolbox2Components: Error initializing toolboxes
Traceback (most recent call last):
  File "C:\Program Files (x86)\ActiveState Komodo IDE 11\lib\mozilla\components\koToolbox2Components.py", line 158, in initialize
  File "C:\Program Files (x86)\ActiveState Komodo IDE 11\lib\mozilla\components\koToolbox2Components.py", line 176, in loadMainToolboxes
    toolbox_id = self.toolboxLoader.loadToolboxDirectory("", stdToolboxDir, koToolbox2.DEFAULT_TARGET_DIRECTORY)
  File "C:\Program Files (x86)\ActiveState Komodo IDE 11\lib\mozilla\python\komodo\koToolbox2.py", line 2063, in loadToolboxDirectory
    os.path.walk(actualToolboxDir, self.walkFunc, False)
  File "C:\Program Files (x86)\ActiveState Komodo IDE 11\lib\mozilla\..\python\lib\ntpath.py", line 263, in walk
    walk(name, func, arg)
  File "C:\Program Files (x86)\ActiveState Komodo IDE 11\lib\mozilla\..\python\lib\ntpath.py", line 259, in walk
    func(arg, top, names)
  File "C:\Program Files (x86)\ActiveState Komodo IDE 11\lib\mozilla\python\komodo\koToolbox2.py", line 1999, in walkFunc
  File "C:\Program Files (x86)\ActiveState Komodo IDE 11\lib\mozilla\python\komodo\koToolbox2.py", line 1961, in _testAndAddItem
    new_id = self.db.addTool(data, data['type'], path, fname, parent_id)
  File "C:\Program Files (x86)\ActiveState Komodo IDE 11\lib\mozilla\python\komodo\koToolbox2.py", line 843, in addTool
    notifications = toolMethod(new_id, data, item_type, cu)
  File "C:\Program Files (x86)\ActiveState Komodo IDE 11\lib\mozilla\python\komodo\koToolbox2.py", line 901, in _add_tutorial
    cu.execute(stmt, (valueslist))
OperationalError: no such table: tutorial
ERROR:xpcom:Unhandled exception calling 'int8 * getStandardToolboxID(out retval int32);'
TypeError: int() argument must be a string or a number, not 'NoneType'
ERROR:xpcom:Unhandled exception calling 'int8 * initialize(in nsISomething);'
Traceback (most recent call last):
  File "C:\Program Files (x86)\ActiveState Komodo IDE 11\lib\mozilla\python\xpcom\server\policy.py", line 303, in _CallMethod_
    return 0, func(*params)
  File "C:\Program Files (x86)\ActiveState Komodo IDE 11\lib\mozilla\components\koToolbox2HTreeView.py", line 232, in initialize
    self._std_toolbox_id = self.toolbox2Svc.getStandardToolboxID()
  File "<XPCOMObject method 'getStandardToolboxID'>", line 3, in getStandardToolboxID
Exception: 2147500037 (NS_ERROR_FAILURE)
[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [koIToolbox2HTreeView.initialize]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://komodo/content/toolbox/toolbox2.js :: Toolbox2Manager.prototype.initialize :: line 71"  data: no]
+ toString (function) 3 lines
+ message (string) 'Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [koIToolbox2HTreeView.initialize]'
+ result (number) 2147500037
+ name (string) 'NS_ERROR_FAILURE'
+ filename (string) 'chrome://komodo/content/toolbox/toolbox2.js'
+ lineNumber (number) 71
+ columnNumber (number) 0
+ inner (object) null
| + data (object) null
| + stack (string) 'Toolbox2Manager.prototype.initialize@chrome://komodo/content/toolbox/toolbox2.js:71:4
this.onload@ch'...366 chars
+ location (object) JS frame :: chrome://komodo/content/toolbox/toolbox2.js :: Toolbox2Manager.prototype.initialize :: line 71
| + QueryInterface (function) 3 lines
| + language (number) 2
| + languageName (string) 'JavaScript'
| + filename (string) 'chrome://komodo/content/toolbox/toolbox2.js'
| + name (string) 'Toolbox2Manager.prototype.initialize'
| + lineNumber (number) 71
| + columnNumber (number) 4
| + sourceLine (string) ''
| + caller (object) JS frame :: chrome://komodo/content/toolbox/toolbox2.js :: this.onload :: line 241
| + formattedStack (string) 'Toolbox2Manager.prototype.initialize@chrome://komodo/content/toolbox/toolbox2.js:71:4
this.onload@ch'...366 chars
| + stack

I’ve tried uninstalling/reinstalling - but have now accepted that solving this issue is beyond me. Does anyone have any suggestions or ideas on what I could try? Despite coding entirely in python, I still far prefer Komodo to pyCharm and would love to see if IDE fills in some gaps with Edit.


Please located the “tools” folder within your profile folder. Stop Komodo and then rename this folder to “tools2”. Now start Komodo again. Does the toolbox load? If so, shut down Komodo and start copying files back from your tools2 folder to your tools folder (not all at once). Each time start Komodo to see if it runs, you will eventually hit a tool that causes this issue. Please share the tool in question with us.

Note this sounds very involved but it really isn’t if you apply an appropriate technique: just start by copying half of the files. Each time you find which half of the files you are copying is causing the problem you cut them in half again, until you hit the problematic file.

I apologise for the inconvenience.

1 Like

Thanks for the response! Renaming the folder (and therefore removing all tools) has the toolbox working again. I’ll try and find the problem tool now.

From what I’ve tried so far, any of the tools inside the ‘Tutorials’ folder within ‘tools’ is causing the issue on Komodo IDE 11 startup. This includes:

The_Toolbox.ktf, Pyramid_Setup.ktf, Rails_Setup.ktf, Getting_Started.ktf, Drupal_setup.ktf, Laravel_Setup.ktf, Django_Setup.ktf, Flask_Setup.ktf, Catalyst_Setup.ktf, Version_Control.ktf.

I think more than one of these is the root of the problem, though at current I can’t discover which ones. If you’d like me to zip them and send them over, let me know the most convenient way for me to do that for you.


That seems unlikely given that we supply those and we’ve not seen this issue anywhere else. Are you certain moving just those tools aside fixes your toolbox?

If so please do share.

Restarting in safe mode shows with the Tutorials files in the toolbox all working correctly. However, copying the tutorial folder from the ko-temp profile into the active tools folder still causes the toolbox not to showup on IDE launch.

Closing Komodo, deleting the tutorials folder and restarting - the toolbox loads properly again. I’m very confused!

That’s very strange. Please do share the tools that you believe to be causing this issue so I can see if I can reproduce.

I’ve put the tutorial directory on wetransfer here : https://we.tl/LoqYzkgC7K

I don’t really understand why when running in safe mode, the exact same files have no problem. Maybe something to do with my user account elsewhere due to trying older version trials and older Komodo Edit? I’m experiencing the exact same issue on a machine at home.

In the meantime, since I don’t need the tutorial files and am happy without them, since that works - I’m going to go ahead and pick up a personal license at some point this month. The Symbol Browser is something I’ve increasingly been needing that Edit misses, and I’m sure there’s a ton of functionality I’d love that I have no idea about…

1 Like

That’s great to hear :slight_smile: Keep in mind the sale runs till the end of this month.

I cannot reproduce your issue using the tutorials provided. Very strange. Let me know if it pops up again.

1 Like

I tried to reproduce, but I’m unable to.
Also compared the files from weTransfer with the ones in my profile folder, but they are identical.
I have no idea what is causing the issue.


Thanks for trying guys - I’m going to assume my problem is either user-permission based, or some issue created by having older versions installed a while ago - as that’s all I can think of that would cause this problem on both my work and home machine!

Either way, I’m very happy that simply removing those files seems to get it working again. Thanks again for your help.