Komodo IDE 11 perl warnings enabled by default?

Hi Community,

I upgraded from Komodo 10 to 11, and found that when I run a perl script (with or without debugging), that has some warnings in it (e.g. use of uninitiated values), the warnings are output by default. It’s as if Komodo 11 runs the scripts with the -w flag. Komodo 10 (still installed) does not do that.

I’ve searched in vain for a setting that controls this but haven’t found it so far. Any ideas? (Please do not suggest I resolve the warnings :slight_smile:, I would love to, but I’m using libraries that are not under my control and can’t always resolve the issues at hand. I really just need to be able to run and see the output without warnings.)

Many Thanks!

What do you mean by “are output”? What are you seeing exactly?

Apologies, I was able to narrow this down to a difference between “Debug -> run without debugging” and running with debugging (Debug -> Go/Continue). There is no difference in behavior as far as I can tell between IDE 10 and 11.

If I have a script that generates a perl warning, like the (contrived) example below

my %foo;

print uc $foo{bar};

If I run this script with “Debug -> Go/Continue”, I see no warnings.
If I run the same script with “Debug -> Run without Debugging”, I see the following (expected) warning in the komodo output pane:
Use of uninitialized value $foo{"bar"} in uc at C:\Temp\noname1.pl line 3.

These are equivalent to running the script from the command-line without and with the -w option:
perl myscript.pl
perl -w myscript.pl

At this point, there is nothing wrong, (I can just use the debug option to avoid warnings), but I am wondering why there is a difference in the two ways of running the script and whether this can be controlled somehow?

Thank you in advance for your time!

Thanks for explaining, that helps! @mitchell do you have an answer? I could certainly give an educated guess otherwise.

I do not have a definitive answer. I would guess that the run without debugging command is different from the debug command.