Komodo Find Highlighting hard to see

Hey @careyh - not really a bug but the thing I find most aggravating about Komodo 9/10 is the highlighting. Specifically, when using any of the “Find” utilities. I always use a dark theme (typically 3024) and while it is great for most things, I cannot figure out any way to make the highlights from a “Find” visible. It also seems that to fix this, I have to modify the highlight color scheme for each language/file type used by Komodo. Maybe there is an easy way to fix this that I am overlooking, but having to search a 5000+ line Python code for a specific keyword, and having the highlights unusable is pretty annoying. If you want me to file a bug report or supply pictures I can, but at this point, I am just using the default 3024.

Hey @bellbrad13 ,

Are you using 10.2.2? There were color scheme changes that went into 10.2.2 that helped significantly with Editor contrast. I was certain that the Find was fixed as one of the persons pushing for those changes was me. I can’t to always change them to something more contrasting.

Note that these changes were made to the Default colour scheme as that is the scheme the issues were reported against so if you’re not using please try it and make sure you’re using Komodo 10.2.2.

This isn’t the case. You just need to change the Find Highlight variable in the colour scheme editor in the Editor section (Tools menu > Color Scheme Editor). Checkout the screenshot below which should make that more clear.

  • Carey

I found that option and was going to come back and tell you I figured it out - but you already jumped in with exactly the same steps that I followed. Thanks for the fast response - that Editor option on the Color Scheme tab had pretty much everything I was looking for. Komodo is back to its normal level of awesome. :slight_smile:

Awesome! Hope you liked the new color scheme editor! Nathan worked hard to try to improve that experience drastically. Feedback from the community helped a lot in the new implementation too.

Glad you’re sorted! @bellbrad13, do you mind if I break your comments out from this thread into a new thread that is specifically about fixing colour scheme issues?

@careyh Go for it! I suspect a few others are having the same issues. I was chatting with a couple coworkers who also use Komodo and evidently we had all been overlooking the “Editor” section of the Color Scheme tab.


@bellbrad13, done. Thank you.