Komodo executes script other than the one in the tab selected


#1

A couple months ago I posted this problem in the bug tracker (#3873). It shows nobody has been assigned to it. Is the bug tracker no longer in use?


#2

Thanks for following up. I think I missed that one.

Can you clarify how you’re executing the script? eg. pressing F5 (debug), pressing F7(run without debugging) or Ctrl + B (run in modal terminal)?
Have you noticed a pattern? Is it the same file that gets run instead of the current file?

If you’re pressing F5 or F7 do you get the debugging settings dialog? If not, press Shift + F5 to get the dialog back. Confirm that you haven’t created a Configuration that always starts the debugger with the same file (ie. if you are starting a program rather than a single script).

Anything more details you can think of will be helpful. BTW, i’m following up here rather than in the Github issue report because I certain this is not a bug and actually has something to do with your setup. I think a lot more people would be complaining if there was a bug in Komodo like this. So ya, lets figure out how to get your setup working as your expect it to.

  • Carey

#3

I’ve been seeing this problem for several versions (at least 8?) on Windows, but it’s intermittent and I have never spent time trying to narrow it down to a reproducible report.

It generally happens when I use Control-F5 and maybe Control-F7.

One possibly useful data point is that the name of the script in the debugging options window is not the file that is currently displayed in the editor. From memory it is a previously run file.

I think closing any open debug tabs seems to fix the issue, but my memory could be wrong there.

If it happens again then I’ll have a closer look and save the logs.