Komodo Edit on WSL2 refresh file problem


Opened 1 XML file in Notepad++ and Komodo Edit

  1. Changed in Komodo - Notepad++ refreshed ok
  2. Changed in Notepad++ - no any refresh in Kamodo, I waited fro one hour in background, clecked on app windwos to make it active also. That’s the problem. File tree doesn’t refresh also
  • Win10 LTSC
  • Ubuntu 20.04 on WSL2
  • Komodo 12.0.1 build 18441
  • Disk mounted as network drive (net use)
    Just on reqular HDD working well

I’m not able to reproduce this though I’m not sure I understand the repro steps correctly.

I did the following:

  1. Created a file, opened it in Komodo and Notepad (not notepad ++ mind you)
  2. Edited file in Notepad and saved
  3. Go back to Komodo and file is updated with new content

It might be a preference: Edit menu > Prefs > Workspace > File Status in Project Manager and Toolbox, though I don’t think this is related to actual file contents.

  1. Create file
  2. Open it in ++ and Komodo
  3. Change and save ir in ++, check in Komodo, no changes
  4. Change and save it Komodo, check in ++, the changes exists


VS Code working well too

This actually sounds really familiar. I feel like someone hit an issue like this in the past. Something to do with how Notepad ++ saves files that Komodo fails to detect (but evidently VS Code works).

I can’t think of what it might be off the top of my head though and it’s working for me.

Can you try some debugging steps on your side? Restart in safe-mode, restart computer, re-install, etc.

Ok, what I did:

  1. Safe mode has no sence bacuse no WSL2 and net use mounting the

  2. Completely uninstalled Komodo, clean up profile in AppData manually

  3. Rebotted

  4. Made the fresh install

No difference, no refresh

I can tell you more. I renamed file in Totak Commander, I see changes in started Explorer, but Komodo tree view is still the same/ I can refresh it but Komodo relaunch only

Appologies but I don’t understand your first point. What does WSL2 have to do with Komodo? Perhaps clarifying your work environment might help as this implies a setup that perhaps might not work as expected.

NP. I mounted Ubuntu on WSL drive via net use. Than I work with data as the regular files and files refreshed and tree refreshed aslo, but not in Komodo. I already tried Notepad++, VS Code, PHPstorm

@MaxA I’m really not sure if that can or should work with Komodo. I think the file watch code that Komodo uses was written long before WSL was a thing.

If you could provide the setup steps for a minimal viable working example, with the required commands i’d need to run, I could try and find some time to do a deeper dive into what might be going on here.

  1. Install Ubuntu 20.04 on WSL2, a lot for manuals in net, ht’s simple, not any deep tunning. You’ll need Windows terminal. Info in the net also
  2. Mount WSL partition via net use, many info in net also
    I use “net use U: \wsl.localhost\Ubuntu-20.04 /user:user passwd”
    The disk is mounted as drive U:
  3. Create or open any file in Komodo and Notepad++, for example, remember about permissions
  4. Change in one, check in the another

Everything is standard and simple. If you have LTSC as mine use this to install MS store: https://www.reddit.com/r/Windows10LTSC/comments/s88jre/guide_activateinstall_windows_store_without_an/

Sorry @MaxA,

I’ve been too busy to give this a deep dive. I’m not sure when I’ll have time to take this for a spin but it’s still on my radar fwiw.

HP, just remember