Komodo edit not picking up python path

I am running Komodo edit 12.0.1 and python 3.8 on Windows 10. The Python directory “c:\python38” is in the system PATH and if I type python at the windows command prompt it runs with no problems. However in Komodo, when I add the python path to Python 3 in preferences and then try to do a run command "%(python) %F it says the python interpreter is not found.

Not sure what to try next.

Hi @larrywm86,

Use %(python3). That should do it.

  • Carey

Hi @careyh , that worked, (hitting my self on the head :slight_smile: )
Thanks very much, I am new to Komodo but really like it quite a bit. Have a great day

1 Like

Hi @larrywm86, I am a new user and had the same issue. Can you please spell out the entire command with the correct syntax? Would it be %(python3) “%F” ? That’s what I have now, but it won’t execute the command without the line of code being selected. I get a window pop up saying “Cannot ‘operate on selection’ because the current file does not have a selection” . If I select the lines it will execute. But in the LinkedinLearning Python3 tutorials by Bill Weinman, he isn’t selecting the text before using Ctrl-Shift-R to execute the run command. What am I missing? Thank you! ~ Sean

I see you are replying. Let me add some new info. It is showing “Hello, World” in the Command Output when the line is selected. But it won’t evaluate the second print line. And more, when I change “Hello, World” to some other text, it still prints “Hello, World” as the result. Very strange.

@stardial, sounds like you selected “pass selection as input” in your Command. Right click on your Command > Properties: disable the above.

You’re right, I had that selected. De-selecting it did not change the result I am getting in Command Output however.

Okay, I have %(python3) “%F” as my run command, and I deselected the “pass selection as input”. Am I on the right track?

It’s working now, and I see that I need to save the file before it will evaluate correctly. Does that sound like the way it should be working?

Yep, that sounds right @stardial.