Komodo Edit IDE 8.5.3: Autocomplete for PHP not working

Hi everyone! I seem to have been having a problem with the autocomplete feature for PHP. I have been having problems for a while now; I’ve installed and reinstalled the application multiple times. It seems like the Komodo is stalling when it tries to implement the autocomplete; I’ve attached a screenshot of one of those times. Can someone help me or tell me what’s wrong with the settings for PHP? Thank you!

By default, PHP will scan everything you have in your PHP include path (i.e., whatever directory you have in the include_path directive). That often includes the typically huge system-wide PEAR directory. That’s a lot of stuff and Komodo can’t cope with it.

I filed a request some time ago but it hasn’t got much attention so far. My workaround is to simply remove PEAR from system-side php.ini file. I normally only use PEAR for command-line applications and whenever I actually use PEAR classes to write PHP code, it’s cleaner to change the directive only for that project.

1 Like