Komodo Edit display problem in VMWare guest

I have installed Komodo Edit 9.1 in the following configuration:
host: Windows 7
VMWare Workstation 10
guest: Mint 17.1 (Rebecca)
When I go away from it and have to unlock the guest OS to return, the Komodo Edit display is a mess - there are repeated lines and incomplete lines. In order to resume working, I have to exit the program and re-start it.

Has anyone else seen this? I don’t know if it’s a problem with Mint 17.1 (I have a laptop with Mint 17 and Komodo Edit works perfectly there) or if it’s a problem with using it in a VM (I only have one VM installed at this point). Any opinions or suggestions would be very welcome!

I have not seen this. Are you using 3d/2d acceleration?

I am using 3D.

Try disabling hardware acceleration in Komodo:

  1. Open a file
  2. Preview the file “in a browser” but set it to open in a Komodo tab
  3. Replace the file address with about:config to get into the settings
  4. Look for layers.acceleration.disabled and set it to true
  5. Restart Komodo

I don’t understand but I tried your steps anyway and the result is the same, once the VM screen needs to be unlocked again, Komodo Edit screens are really messed up.

What I don’t understand is using the browser settings to disable acceleration in Komodo Edit. Wouldn’t it make more sense to use the VM Settings -> Display, and uncheck “Accelerate 3D graphics” (which is the default, AFAIK).

I am working on a perl script that I run in a terminal, I haven’t been using a browser at all in the VM. In order to follow your directions, I opened an HTML file in Komodo Edit. I left that file open until the screen lock/unlock and its display was a mess, too.

The browser window just facilitates you opening about:config in Komodo. It affects Komodo itself.

I didn’t want to default to asking you to disable 3D in your VM since that seems far more drastic. But for the sake of troubleshooting could you try that to see if it makes a difference?

Thank you for the explanation! I have been using Komodo Edit for perl only, I didn’t even know about the browser. I have to say that in spite of the current problem, I am very grateful for Edit - by saving me from typos and syntax errors, it leaves me free to concentrate on the logic and I am able to stay on-track much better!

I disabled the VM’s 3D and have unlocked it three times now with Komodo Edit open and have not seen any display problems. Mint does complain about it and I would appreciate a better solution but I think I’ll try to work with this for now. Finding my code has disappeared or been corrupted on-screen is distressing even though I know I just have to restart Komodo Edit to fix it.

Thank you!

Honestly this sounds more like a VM issue than a Komodo one, I would suggest playing around with your VM’s video settings. Also ensure you’ve installed the latest VM tools on your guest system.

You’re probably right, I’m sure you know a lot more about this than I do. When I have some time I’ll try installing Mint 17 in another VM (I have that on a laptop and Komodo Edit is perfect there) and see if that works better than this Mint 17.1 VM.

My VM tools are up to date. I can’t find any VM video settings to change. I did change the “lock screen” setting to never lock the screen, that makes no difference.

I also leave gedit and a terminal open when I take a break, their displays are always normal when I return.

Yes, it was the VM! I started seeing other issues with it and installed another VM using Mint 17 Qiana. Komodo Edit has no problems on that. Thank you for your help.