Komodo Edit crashes when tried to open color picker window on Mac OS X 10.10 Yosemite

Lately I have had a lot of crashes on Yosemite.
Everytime I try to get the color chooser using command and clicking on a color already present, Komodo edit crashed.

Is there a solution to this?

I think Komodo 8 is not optimized for Yosemite now, but anyway attach your log after crashing. (/Users//Library/Application Support/Komodo[IDE|Edit]//pystderr.log) :smiley:
Also I rename title of your topic just for displaying your problem a bit more correctly :blush:

Nothing about color picker in log…
@toddw can you look at it?
Also try nightly builds or Komodo IDE 9

Was this log copied when Komodo crashed, before you had restarted it?

Nope, it was after I restarted it :confused:
I will copy it again and reply to this post :smile:

Hello Nathan
here is the log file as i came across the problem again.

IDE 9 still crashes :confused:

Try to change Color picker to use in Prefs - Fonts & Colors

Hmm nothing of use in that log. Do you get a “Komodo has crashed” dialog after Komodo crashed? This should be able to give you debugging information as well.

Workaround: Change the default color picker (in Komodo’s Fonts And Colors preferences) to a different one.

Komodo bug logged here:

Just FYI, I’ve been having the same issue. This seems to have solved it, which is nice, it’s been a pain.