Komodo Edit 8.x - function arguments calltips not working

Hello,

I’m using Komodo IDE, I have installed both 8.5.4 and 8.0.2.
I switched to the 8.0.2, because I didn’t have calltips for both PHP functions and custom methods.
With 8.0.2 I have everything for my own classes and methods, but still nothing for PHP functions.
I read and tried few threads from hear - with no success.
Here is the error log:
http://31.13.223.42/komodo-error.log
Please help - it seems the internet is full with such errors.
I’m still using Komodo Edit 5.2 on my Windows machine and there was no such a problem at all!
No delay, no long scanning and building codeintel, no fails.
I start to regret I bought this IDE - if the core PHP functions’ calltips are not working - it’s not usable at all!

Nikolay

Edit1: I’m on Ubuntu 14.04

Edit2: I used to try this: http://community.activestate.com/faq/codeintel-database-fix before I post here, and it didn’t solve my problem!

Hi Nikolay! There are few things you should know:

This version is really old. You shouldn’t use that.

Komodo 8.5* is no longer actual Komodo version, you should move to Komodo 9 and try that.
Also can you attach an example file where codeintel doesn’t work? I can see codeintel.tree: Unexpected error with evaluator: 'date' at cron_export_all.php#46 error in the log so can you share this line with us? Also you can try to remove your codeintel folder to re-create CodeIntel. (Depending on your nickname I guess you’re from Russia or you can speak in Russian so you can read this guide to find your codeintel folder:


)

Many thanks for the fast answer!

I’m from Bulgaria and I’m fine with Russian, but I forgot to say that I already tried the method with removing codeintel. I added it to my initial post seconds before your reply.

Here is the beginning of the file where this happens (it’s part of a project):

<?php
$cron_jobs = new read_table_field_value('cron_job', array('import_export' => 'export', 'active' => '1'));
if (!$cron_jobs->has_rows)
{
    while (($row_cron_job = $cron_jobs->read_next_row()) !== FALSE)
    {
        $date             = date("U");
        //$date_now         = date("Y_m_d_H_i", $date);
        
        $arr_date         = getdate($date);
        $year             = $arr_date("year");
        $month             = $arr_date("mon");
        $day             = $arr_date("mday");
        $minute         = $arr_date("minutes");
        $hour             = $arr_date("hours");
        $date_prev         = mktime($hour, $i, 0, $month, $day, $year);
        $date_prev_Y     = date("Y_m_d_H_i_s", $date_prev);
...

I asked you for the line #46 because Komodo cannot deal with this line so can you share it? :smile:
(also it’ll be better if you share the whole file to PM)
Also please try Komodo 9.

Here is the whole file:
http://31.13.223.42/cron_export_all.txt
I just renamed it to txt.
I’ll install Komodo 9 to give it a try.

Doesn’t work at me in Komodo IDE 9. Thanks for the report, Nikolay! (btw it happens only in the code you gave, it works for me in any other file).

I find the problem @nikolay_ivanov!

$date             = date("U");

Please change the name of the variable. I’ve changed it and tooltip works fine.

1 Like

I can confirm - changing the variable name solves the problem.
It’s the same in KomodoIde 9 - I just installed it and the same behaviour is there. Changing the variable name solves the problem.
I tried with several other PHP function and no one else seems to brake the autocomplete, except the $date.

Thanks for the help!
Really appreciated!

Try to write this code:

$getdate = 1;
getdate();

You won’t see a tooltip for getdate function. That’s very strange and I already reported about it.
Best regards.

1 Like