Komodo edit 8 - Linux and KPF project file problems drving me nuts!

I switched from Windows to Linux in 2009 and with that switch went from Notetab Light to Komodo Edit 5.0 at the time. The reason for the switch to Komodo was because it enabled me to copy/paste my old eBay template files into new komodo html snippets which I could then save as a project file. It was a little bit more cumbersome than the straight text with Notetab, but in my opinion better than using Wine as I wanted to get used to using Linux without any Windows software assistance.

Never looked back … Komodo Edit 5, 6, and finally 8 all worked with Linux since 2009 … until now that is. Actually Komodo Edit does work just fine, but I’m having a serious issue with my saved project (KPF) files.

Day before yesterday (Sep. 23rd) was the last time that I used Komodo for a couple of eBay listings. Today I was going to list a few more items but when I opened Komodo Edit … all of my project snippets were no longer visible. Eventually I figured out that it had to do with me deleting my old Komodo 5.2 folder from my Linux home/user directory. I have no idea why Komodo Edit 8.5.1 would use anything out of there, but ah well, my bad.

Not to worry, I went ahead and removed everything Komodo related from my system … followed by performing a fresh install of Komodo 8.5.1 which worked without a problem. My project files were backed up of course, so no problem there either … or so I thought.
I have spent the past 4 hours trying to get me project files to work !!!
At this point I’m about ready to jump out of a window or something !!!

I can open a project file … use the open window to locate one of my backed up projects … select the project itself … and click on open. The project then appears in my left project pane as it should. However, the .kpf file is no longer expanded. I see the closed .kpf file as my project file with the correct title, but none of the snippets within that .kpf project file are visible.

I’m losing my mind here !!! Since this problem began I’ve reverted to Komodo Edit 6.1 and 8.1 and now back again to 8.5.1 with the same problem continuuing endlessly. 6.1 just keeps on crashing in my Linux Mint 17 setup. But Komodo Edit 8.x works just fine … except for epxanding my project file.
What on earth is going on?
Please, I really need to get this fixed as of hours ago … Thank you.


I’m confused what you mean by “expanding the .kpf file”. What are you looking to find when it is expanded? Are you not seeing a file listing of your project?

I don’t know how to explain it exactly, but ever since I’ve been using Komodo I initially started out with a blank project file. Then I would add individual code snippets to that project. Eventually over time I’d even create sub-folders with additional more specific code snippets, all as part of the same project. Using the context menu in the title of the project, I would save the entire enchilada as filename.kpf
The kpf was by default … not my invention or doing.

Anytime that I would install Komodo thereafter on my Linux setup which ranged from Ubuntu to XFCE to Debian to Mint, and so on, all I’d need to do was to import the previously saved .kpf file from it’s saved location, and instantly I’d have the project with all of it’s snippets back open in my left project pane. That may not be how you’re supposed to use project files but way back in Komodo Edit 5.2 it was the only way for me to do what I was trying to accomplish.

Anyway, here’s what used to happen before today. When I imported a project file it would appear by name in the left pane with a tiny little arrow or triangle which I could click on to expand the files or snippets that were contained in my project. One click and all of my custom snippets became visible, to be used individually as I double-clicked on one of the visible snippets. But as of today, I have the project file in my left pane … but it won’t expand to show all of my snippets and sub-folders with more snippets. If I right click I can see the “OPEN” option, but selecting that does nothing. Close project (to import another backup) does nothing. Close all open projects does nothing. I simply can not do anything with my previously saved .kpf project files after importing them … even though I can clearly see the contents of my .kpf project files from within my Linux file manager. So I know for a fact that my snippets are there … but can’t seem to utilize them in Komodo Edit any more.

I’ve checked permissions across the board and that’s not the problem. I’ve assigned admin privileges everywhere just to be sure.

When you say you were adding your snippets and what not, do you mean under the Project folder in your Toolbox, or did you create your own structure in your Places widget (you can see the name of a widget/pane by hovering over its icon)?

Perhaps it would be useful if you could post a screenshot of what you are seeing and indicate what item you wish to expand.

Maybe some details on how Projects work would help.

When you open a project file, it will have a “toolbox” folder that opens in the View > Tabs & Sidebars > Toolbox. This is where you would save your snippets, macros and commands and other tools.

In the View & Tabs & Sidebars > Places pane, the project will show it’s self in the Project section of that pane. Here, if you’ve added files or folder (Right click > Add > FIle/folder/blah) those are saved as a reference to those files or folders so they are easier to access from your project.

One thing that would help, as suggested by @nathanr, would be if you provide a screen shot to clarify which you are talking about.

Another would be to show use the contents of your *.kpf.

It sounds like you’re talking about the “Places” context in which case the contents of the *.kpf file would be helpful.

  • Carey

Okay, I finally got it working properly. The screen shots should explain the rest.
I don’t think there was an actual solution … just a different manner of using the newer Komodo …

I’m not sure how you could have landed on this structure, as it is not a structure Komodo uses.

Normally your structure would look like this:

  • MyProject.[kpf|komodoproject]
  • .komodotools
    • Abbreviations
      • snippet.komodotool
    • command.komodotool
  • Project Folder 1
  • Project Folder 2
  • Project File 1
  • Project File 2

It seems somehow your project is placed within the .komodotoolfolder itself and you added a prefix to this folder. I can only assume that you did this yourself at some point without realizing the implications.

If you wish to use Komodo as-designed I would recommend you try and mimmic the structure I demonstrated above. You should be able to do this by renaming My.Komodotools to .komodotools and moving it to the same folder your .kpf file is in, then reopen your project.

Well, I really believe that all of the "weirdness has something to do with files changing across various different Windows/Linux platforms where I’ve had to make adjustments of my own to make Komodo work properly with whichever Linux flavor I was working with at the time. I really wish I knew how (which I don’t), or at least that ActiveState would make .deb files available. Gosh, that would really simply installations on any Linux flavor with the apt environment (Ubuntu, Kubuntu, Lubuntu, Xubuntu, Mint, and several other Linux flavors). Consider this … with a .deb file the installation is a no-brainer which isn’t true otherwise since, in particular Linux Mint and straight Debian, don’t always use identical installation paths of applications. Sometimes it’s usr/opt/ … other times it’s home/user/.application … and so on. I believe a .deb file would eliminate much confusion for those of us who love Linux, yet aren’t old time Linux gurus.

I’ve never liked projects which is why I never use them. I prefer “my archive” of custom snippets and a manual selection of files for whatever project that I may be working on since the folder path to such projects may change from one drive to the next, or to another computer, or a partition with a different name. The manual selection works every time no matter what.

Having said that though, back in 2009 there was no choice for me. According to the assistance that I received from ActiveState at that time, projects were on the left and tools were on the right … period. So if I wanted to use my snippets on the left side, I had to move that snippets folder over to the projects location. Perhaps that started the mess that I eventually got myself into. Well, I’m going to just ignore the project pane altogether while continuuing to work with the toolbox pane and my now properly working snippets.
Thanks again for the assistance, and before I forget …

Komodo Edit is IMO the world’s absolute hands down code editing solution !!! Would jump through hoops to continue using it no matter what OS is installed on my machines !!!

Ok lets just boil down to what seems to be the main problem here; you’re managing tools through a project.

To resolve this; could you simply open the folder that contains all your tools via your file browser (presumably Nautilus) and drag all of those tools right into your toolbox? That should import them into the right place, and from there you can use (or not use) projects to your hearts content. Just dont put your tools (snippets, macros, etc) into the actual Project files, as that is not where they belong.

Also I just want to point out that though your profile location may vary per OS, the file structure remains exactly the same. It seems you may simply have been lead to believe that things were far more complicated than they are in reality.

Finally, we do not currently provide a .deb but if you use Komodo Edit you can use the community provided repo here: https://launchpad.net/~mystic-mirage/+archive/ubuntu/komodo-edit

Thanks for the links, I’ll have to check that out. As stated though, I’m not using the project pane any more since everything is now located in the toolbox pane. I just moved that one to the left side, that’s all. Hopefully this should fix the issue once and for all. Knock on wood …
Take care.