Komodo Edit 11.1 - Synax checking status icon no longer in status bar?

Hi, how can I see the syntax checking results on the status bar as it was in Komodo Edit 9? Has this essential functionality been removed?

Thanks for your help

It was moved to the Dynamic Toolbar:

1 Like

Understood, thanks for your help!

1 Like

@gpmc, no problem.

Thanks again careyh, although I have to admit I’ve switched back to KE 9.3, due to the following:

  • The syntax checking icon forces me to use the toolbar which takes plenty of screen space, and I use nothing else on it. It was much better when it placed in the status bar.

  • Find results tabs cannot be closed.

  • The find dialog does not close automatically (even though the setting to disable auto-closing is turned off). I have to get back to the Find window and click Esc, very uncomfortable.

  • Various small bugs make the product seem unfinished. One small example that I recall is: set a color in the custom scheme editor to #000000, and it won’t register. It keeps reverting back to the original color. But save it as #000001, and it works. Probably considers the bunch of zeros as null or something similar. Another issue: choosing Find Results as File Tabs just doesn’t work, returns a scintilla error.

I’ll try to check out Komodo 12 once it’s released. Thanks for the good work anyway!!

  • Dynamic Toolbar: As the name implies, the tooling available in this bar changes as you work. You’ll find it very useful if you get to know it. I don’t miss the 100px you lose. You can disable it if you want though.

  • Find Results: Need more info. Find Results closes fine.

  • Please file bugs to get things fix. Just dropping them in a forum post won’t get much attention on them: https://github.com/Komodo/KomodoEdit/issues/new

  • Carey

Thanks Carey, I don’t have this version installed anymore but as far as the find results tabs go, I was using the bottom tabs with icons only (no text in their titles), and the close button just wasn’t there on the Find tabs. It didn’t cross my mind to switch to ‘icon and text’ mode for the tabs, this may have solved it.

Thanks again for your attention