Komodo breaks at a line even after removing the breakpoint

I’m debugging a php file in zend project. Earlier i set a breakpoint in a php file and i removed it later. Now there is no breakpoints set in my whole project . But still komodo breaks at the previously set breakpoint. How to disable it completely
I’m working on Komodo IDE 10 trial version and the operating system is Ubuntu 12.04

Open the bottom pane, “Breakpoints” tab. They should be there.

No its empty

Do you have breakpoints.pickle in your profile folder? (~/.komodoide/10.0/)

Yeah I have

Well, remove it then. This should solve your problem.

Ok Let me try

It breaks at the same line even after removing that file

Hmm, try to debug this file in Safe Mode (Help - Troubleshooting - Restart in Safe Mode)


Assume that i’ve 2 php files FileA and FileB. During execution the control will first go to FileA and then FileB. I need to debug only FileB. but it always ask this message to map URI for FileA. also if execution goes into multiple files it shows this dialog for each file

Not sure whether this is the default behaviour or it happens due to the above discussed breakpoint issue

Please change your “Initial break behavior” in Edit > Preferences > Debug > Debugging Session Startup. That may fix your problem.

Yeah now its working fine. Thank you very much. you saved my time