Komodo Alert when trying to change value of a variable


#1

Running Komodo 10.2.2 on MacOSX 10.11.6. When trying to run a very simple Ruby script if I set a breakpoint where it stops, then double-click a Local string variable to change the value, I get the “Edit Variable Value” dialog box. When I click OK I get the following Komodo Alert:

"Error setting value: " with an OK button. After I click OK the variable remains unchanged. The same thing occurs if I select “Interpret as string” or “Interpret as expression”

The same thing occurs if I do it in Komodo 11.1.0 91033 running on MacOSX 10.13.6 on a different machine. I can’t find any way to change the value of a variable when it stops at a breakpoint.


#2

Apparently CDATA dropped some text, the actual alert dialog is:


#3

@bgrudulis, Looks like an issue with our interface with Byebug debugger:

  • Carey

#4

Thanks, what version of byebug should I be using, right now it’s 9.1.0


#5

@bgrudulis, I’m not sure that a different version of byebug would fix this. It might have just been broken since we implemented Ruby debugging for >= 2.0 and no one has tried setting a variable value in the Locals tab yet.

We never recommended a specific version. I have 9.0.6 and it’s still broken. I couldn’t find anything in the Byebug repo about -k option being removed, if that’s what is even returning the error. I briefly dug into the debugger library in Komodo and it generates a command that uses a -k option but it’s passed to something internal and that’s as far as I got before I had to get to other tasks.

I might be able to dig more into this issue this morning.

  • Carey

#6

So right now is the way to get it to work would be to use ruby 1.9.x?


#7

@bgrudulis sorry! Forgot to reply to this. I’m assuming you tried it but yes I believe the best course of action for you will be to use 1.9 if you can. I’m digging through the debug server code to see what’s up. I’ve gotten past the -k error but now it’s failing silently on something else. Print statement debugging time.

  • Carey

#8

@bgrudulis, I thought i’d have a fix ready earlier today but it’s turned into a man sized rabbit hole. You could actually continue using 2.0 and use the interactive shell in the debugger to change a variables value.

  • Carey

#9

@bgrudulis, finally got the issue resolve. I’ll be building/releasing a nightly with the fix once my PR get approved by my team mate. Keep your eye on the ticket I created for that.

  • Carey