Komodo 9 fails to launch on OS X Yosemite

I was using Komodo 8 and it worked, albeit it took a long time to launch. I switched to the latest version of Komodo 9 and now it starts to launch, the icon bounces in the dock, then it just stops without generating a crash log. The only thing I get in the the console messages is “com.apple.xpc.launchd[1]: (com.activestate.KomodoIDE.536792[959]) Service exited with abnormal code: 255”.

Can anyone figure out what’s going on?

That’s very odd. Have you tried downloading a fresh copy of Komodo? Seems like your install may be corrupted.

I just did and the fresh install off a newly downloaded dmg file from http://downloads.activestate.com/Komodo/releases/9.1.0/ did the same thing when I tried to launch it. It bounced twice in the dock and just stopped without a crash report, just the log showing error 255

Try starting Komodo with a clean profile: https://community.activestate.com/node/15233

It does the same thing.

There has to be something going on with your OSX install, something out of the ordinary. We primarily target Yosemite atm and no one else has had any issue starting Komodo as far as I’m aware :\

You might be able to get more information by starting Komodo with komodo -v from /Applications/Komodo\ IDE\ 9.app/Contents/MacOS/komodo

Well, I seem to have figured out what was going on. 90% of my applications are on an external drive, and while Komodo 8.5.4 is quite happy with this, Komodo 9.1 is not. As soon as I copied Komodo 9.1 to my internal drive and tried launching it from there, it worked. But it won’t launch from an external drive. So something did break between 8.5.4 and 9.1, but you wouldn’t notice it unless you tried launching it from a non-default drive.

That’s odd. We did upgrade to the OSX 10.9 SDK with 9.0, perhaps that’s related.