Komodo 11 - Using Custom Templates

I just upgraded from Komodo 10.x to Komodo 11.0 and I cannot figure out how to create a new document from a template that I have created. Previously, I would have:

  • right-click on the folder where I wish to create the new document
  • click New File from Template…
  • selected my desired template in a dialog that would apper, give it a name, hit enter and away I go

Now, when I right-click and select New File from Template… the Go To Anything widget drops down a list of templates, but it does not include any of my custom templates.

Any help would be greatly appreciated.

@baldmantom the new file from template function got a overhaul.
I tested out the new functionality, but the file templates are located in you’re toolbox.
If you create a custom folder and add you’re templates here, the should show up:

@baldmantom, could you file a bug for this so we can look into it? You’re custom templates should not have been left behind.

  • Carey

Oh. Well, there’s my problem. After upgrading, my toolbox is empty. I just deleted the 11.0 folder under ~/Library/Application Support/Komodo Edit/ and tried the upgrade scenario again, and have the same result.

Casey requested I file a bug, I assume this is the one I should be filing?

That is not the correct folder. Remove the space in Komodo Edit for the correct folder. The folder with a space is some Mozilla artifact (Komodo is built on mozilla) that we do not use. You toolbox should not have been empty after retrying the upgrade process and it wasn’t empty before so it worked before. I’m not sure what happened to your toolbox now. Can you rename _~/Library/Application Support/KomodoEdit/11.0 _ and try it again?

File a bug for Komodo not importing your Custom Template Files.

Hi careyh,

I made a mistake in my previous post, it was ~/Library/Application Support/KomodoEdit/11.0 that I had removed. Before I had done so, I had checked my Toolbox, and it had been empty.

Renaming the 11.0 directory to 11.0_ and restarting KomodoEdit 11 bore the same result.

@baldmantom, what’s in Help > Troubleshooting > View Log File after reproducing this?


I’ve created this report to track the issue.

I don’t seem to be able to attach the log file, but it’s there in the issue I filed.