Komodo 11 has many broken functions

I have recently upgraded to Komodo IDE, version 11.0.2, build 90813, platform win32-x86.
Built on Mon Dec 04 08:56:02 2017 from version 10. I upgraded because I couldn’t get v10 to work with Python 3.x, but that turned out to be a “feature” of Komodo in that I needed to explicitly tell it to use Python 3.x

Much of the functionality that I used in v10 no longer works. I have included a small sample file below that illustrates all of the missing functionality

  1. Go to definition (Ctrl-K Ctrl-G): the menu is grayed out and even simple files don’t work.
  2. Refactoring (Ctrl-K Ctrl-M) variables does not work at all.
  3. I have had multiple issues with indentation getting screwed up in the editor - often while editing a file - that requires retabifying the entire file.
  4. I cannot get TortoiseSVN to work with v11. Running the initial installation wizard does not find it in my path, and explicitly pointing it at my TortoiseSVN directory does not work either.

Here is some sample code:

import subprocess

def Usage(app_name):
    print("Usage: %s [-v | --verbose] [-h | --help]  [-f | --inputFormat] [[-i | --inputFile] filename] [[-u | --username] | [-tOutputType | --outputType]] [-U] [-G] " % app_name)
    print("       -h == display program options")
    print("       -f == input Format (%s) default %s" % (INPUT_TYPES, EMAIL))
    print("       -i == input filename")
    print("       -u == output usernames (cannot be used with -e option)")
    print("       -t == outputType (%s) default %s" % (OUTPUT_TYPES, USERID))
    print("       -U == Userids in inputfile")
    print("       -G == use GUI")
    print("       -v == verbose messages")


arrUser = "foo@nvidia.com' , 'bar@nvidia.com"
arrOwner = "schehab@nvidia.com"
mgr = 2155
rootpath = 'C:\\tmp\\encrypt\\'
fileExport = rootpath + 'ExcelFiles\\'
exportFile = fileExport + str(mgr) + '-Org.xlsx'
cmd = 'powershell -command ". \'' + rootpath + 'encryptFile.ps1\'; $arrUser = \'' + str(arrUser) + '\'; $arrOwner = \'' + arrOwner + '\'; $filePath = \'' + exportFile + '\'; EncryptFile $arrUser $arrOwner $filePath '

if __name__ == "__main__":
    # get application name


Very sorry to hear about your troubles, we definitely want to fix those for you. That said, the forum is not the medium for this nor is the format of your post easily actionable. Could you please report your bugs one by one (separate reports) on our bug tracker?

Thank you


Thanks for contacting us.

  1. Once I fixed the syntax error at the bottom of the sample code go to def works fine
  2. Something does appear to be wrong with Refactoring.
  3. I can’t tell what the issue is you’re seeing from the information you’re provided. Reproductions steps would help. Something you could try in the mean time is disabling Prefs > Editor > Indentation > Allow file contents to override Tab and Indentation settings.
  4. How do you know it’s not working? If the Start Up Wizard can’t find it then it likely isn’t on your PATH. Note that your PATH variable can change depending on what context you’re in. Prefs > Environment will show you the PATH that Komodo is working with. For explicitly setting the SVN binary (Prefs > Source Code Control > Subversion), you have to point it at the binary, not a directly. I don’t it’s even possible to select a folder using the Browse button in that window. It only allows selecting files. Not sure how you’re selecting a folder.


Hi Carey,
Thank you for your response. I disagree with some of your findings:

  1. Go to def does not work at all.
  2. agreed :-/
  3. It’s odd - it’s not all files, but all of the Python files I am using worked perfectly well with 2.7. I’ve tried using the preference setting both ways to no avail. The good news is that once I’ve fixed the indentation using then it seems to (mostly) stick.
  4. I know it doesn’t work because nothing is available when I try to use version control from within Komodo. Everything is greyed out.
    Here’s my path: Path=C:\Program Files (x86)\ActiveState Komodo IDE 11;C:\Python36;C:\Python36\Scripts;C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\WindowsPowerShell\v1.0;C:\Program Files\Intel\WiFi\bin;C:\Program Files\Common Files\Intel\WirelessCommon;C:\Program Files\Perforce;C:\Program Files (x86)\Perforce;C:\Program Files (x86)\WebEx\Productivity Tools;C:\Program Files\TortoiseSVN\bin;C:\Users\awolfson\AppData\Local\Microsoft\WindowsApps;C:\Program Files\Microsoft VS Code\bin

TortoiseSVN is clearly in the path - both from the cmd window (above) and Prefs -> Environment.

… and you’re right - I can’t select the bin folder. When I ask Komodo to search again, it fails to find the binary. I’ll try rearranging the order of the folders in my path, but Komodo should be able to find the svn folder without me having to do that.

Thanks again for your responses!


  1. I’ll need reproduction steps if go to def is not working for you.
  2. I thought I had shared the bug report with you but I forgot: https://github.com/Komodo/KomodoEdit/issues/3541
  3. If you figure out reproduction steps please file a bug:
  4. Are you saying you can’t select the SVN binary in the Komodo preferences? Yes Komodo should be able to detect it but if lets get it working first. Just select the SVN executable in the preferences and make sure that works.